CVE-2026-32228
Apache Airflow: Users with asset materialization permisssions could trigger Dags they had no access to
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache Airflow: Users with asset materialization permisssions could trigger Dags they had no access to
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
CVE-2026-32228- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-03
EUVDEUVD-2026-23664
7.5
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
EUVD-2026-23664- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h97w-pm3w-mwmc
7.5
Apache Airflow allows users with asset materialize permissions to trigger DAGs outside of their permissions
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
GHSA-h97w-pm3w-mwmc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
NVD
7.5
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
CVE-2026-32228- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-03
OSV
7.5
Apache Airflow: Users with asset materialization permisssions could trigger Dags they had no access to
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
CVE-2026-32228- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-04
OSVGHSA-h97w-pm3w-mwmc
7.5
Apache Airflow allows users with asset materialize permissions to trigger DAGs outside of their permissions
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
GHSA-h97w-pm3w-mwmc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSVPYSEC-2026-2360
7.5
Apache Airflow allows users with asset materialize permissions to trigger DAGs outside of their permissions
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
PYSEC-2026-2360- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVBIT-airflow-2026-32228 No score
Apache Airflow: Users with asset materialization permisssions could trigger Dags they had no access to
UI / API User with asset materialize permission could trigger dags they had no access to. Users are advised to migrate to Airflow version 3.2.0 that fixes the issue.
- Record
BIT-airflow-2026-32228- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apache-airflow-corePyPI |
3.0.0 up to 3.2.0 | 3.2.0 |
airflowBitnami |
3.0.0 up to 3.2.0 | 3.2.0 |
apache-airflow-corePyPI |
3.0.0 up to 3.2.0, plus listed versions 3.0.13.0.1rc13.0.23.0.2rc13.0.2rc2 Show 45 moreShow less3.0.33.0.3rc13.0.3rc23.0.3rc33.0.3rc43.0.3rc53.0.3rc63.0.43.0.4rc13.0.4rc23.0.53.0.5rc13.0.5rc23.0.5rc33.0.63.0.6rc13.0.6rc23.1.03.1.0b13.1.0b23.1.0rc13.1.0rc23.1.13.1.1rc13.1.1rc23.1.23.1.2rc13.1.2rc23.1.33.1.3rc13.1.43.1.4rc13.1.4rc23.1.53.1.5rc13.1.63.1.6rc13.1.73.1.7rc13.1.7rc23.1.83.1.8rc13.1.8rc23.2.0b13.2.0b2 |
3.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | CVE List, EUVD, NVD, OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-32228 is a high vulnerability (CVSS 7.5) in Apache Airflow, published April 18, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.43%, the 36th percentile. Fixed in apache-airflow-core 3.2.0.
References
github.com/apache/airflow/pull/63338
lists.apache.org/thread/s7c75txgt4qf2rofcn43szfwgcrzy0nj
openwall.com/lists/oss-security/2026/04/17/8
nvd.nist.gov/vuln/detail/CVE-2026-32228
github.com/advisories/GHSA-h97w-pm3w-mwmc
pypi.python.org
github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32228.json
github.com/apache/airflow
pypi.org/project/apache-airflow-core
Left out here: 2 versions. The JSON record has them.