CVE-2026-32278
Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.2
Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32278- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-434
- Updated
- 2026-11-02
EUVDEUVD-2026-14570
8.2
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
EUVD-2026-14570- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mv3p-7p89-wq9p
8.2
Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Security Advisory — Form Plugin (Stored XSS)
Summary
A Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin.
Affected Versions
- 1.x series: <= 1.41.0
- 2.x series: <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the file field of the Form Plugin, Stored Cross-site Scripting (XSS) could occur. If exploited, arbitrary script could run in an administrator's browser, which may lead to unauthorized actions or information theft. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
- Record
GHSA-mv3p-7p89-wq9p- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-79, CWE-434
- Updated
- 2026-11-02
NVD
8.2
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32278- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-434, CWE-79
- Updated
- 2026-11-02
OSV
8.2
Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
- Record
CVE-2026-32278- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-434
- Updated
- 2026-11-02
OSVGHSA-mv3p-7p89-wq9p
8.2
Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
Security Advisory — Form Plugin (Stored XSS)
Summary
A Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin.
Affected Versions
- 1.x series: <= 1.41.0
- 2.x series: <= 2.41.0
Patched Versions
- 1.41.1
- 2.41.1
Description
In the file field of the Form Plugin, Stored Cross-site Scripting (XSS) could occur. If exploited, arbitrary script could run in an administrator's browser, which may lead to unauthorized actions or information theft. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
- Record
GHSA-mv3p-7p89-wq9p- CVSS 3.1
- 8.2 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-434, CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensource-workshop/connect-cmsPackagist |
through 1.41.0 | 1.41.1 |
opensource-workshop/connect-cmsPackagist |
2.0.0 to 2.41.0 | 2.41.1 |
opensource-workshop/connect-cmsPackagist |
before 1.41.1, plus listed versions 1.20.0v0.0.1.20200106v0.0.1.20200216v0.0.1.20200302v0.0.1.20200411 Show 45 moreShow lessv0.0.1.20200510v0.0.1.20200603v0.0.1.20200716v0.0.1.20200909v0.0.1.20201008v0.0.1.20201207v0.0.1.20210104v0.0.1.20210301v0.0.1.20210405v0.0.1.20211130v0.0.1.20220207v1.0.0v1.1.0v1.1.1v1.1.2v1.1.3v1.10.0v1.10.1v1.10.2v1.10.3v1.10.4v1.11.0v1.11.1v1.11.2v1.11.3v1.11.4v1.11.5v1.12.1v1.12.2v1.12.3v1.13.0v1.13.1v1.14.0v1.14.1v1.14.2v1.15.0v1.15.1v1.15.2v1.15.3v1.15.4v1.16.0v1.17.0v1.17.1v1.17.2v1.17.3 |
1.41.1 |
opensource-workshop/connect-cmsPackagist |
2.0.0 up to 2.41.1, plus listed versions 2.30.0v2.0.0v2.0.2v2.0.3v2.0.4 Show 45 moreShow lessv2.1.0v2.1.1v2.1.2v2.1.3v2.10.0v2.10.1v2.10.2v2.15.0v2.15.1v2.15.2v2.15.3v2.15.4v2.16.0v2.17.0v2.17.1v2.17.2v2.17.3v2.17.4v2.18.0v2.18.1v2.18.2v2.18.3v2.19.0v2.19.2.1v2.2.0v2.2.1v2.2.2v2.21.0v2.22.0v2.23.0v2.23.2v2.23.3v2.24.0v2.25.0v2.25.1v2.26.0v2.26.1v2.27.0v2.27.0.1v2.28.0v2.29.0v2.29.1v2.3.0v2.3.1v2.3.2 |
2.41.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-32278 is a high vulnerability (CVSS 8.2) in Opensource-workshop Connect-cms, published March 23, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.20%, the 9th percentile. Fixed in opensource-workshop/connect-cms 1.41.1.
References
github.com/opensource-workshop/connect-cms/security/advisories/GHSA-mv3p-7p89-wq9p
github.com/opensource-workshop/connect-cms/commit/9d87fe8ecf7f57efbb0e5231be058807734c96b3
github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1
nvd.nist.gov/vuln/detail/CVE-2026-32278
github.com/advisories/GHSA-mv3p-7p89-wq9p
github.com/CVEProject/cvelistV5/tree/main/cves/2026/32xxx/CVE-2026-32278.json
github.com/opensource-workshop/connect-cms
Left out here: 138 versions. The JSON record has them.