Every CVE Search/ Get API key

CVE-2026-3304

Multer vulnerable to Denial of Service via incomplete cleanup

8.7 HighPublic exploitFix available

Multer is a node.js middleware for handling multipart/form-data. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.74%Up 0.7 points since Feb 28, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.7

Multer vulnerable to Denial of Service via incomplete cleanup

Multer is a node.js middleware for handling multipart/form-data. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Record
CVE-2026-3304
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-459, CWE-459
Updated
2026-11-02
EUVDEUVD-2026-9033 8.7

Multer is a node.js middleware for handling multipart/form-data. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Record
EUVD-2026-9033
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-xf7r-hgr6-v32p 8.7

Multer vulnerable to Denial of Service via incomplete cleanup

Impact

A vulnerability in Multer versions < 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion.

Patches

Users should upgrade to 2.1.0

Workarounds

None

Record
GHSA-xf7r-hgr6-v32p
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-459
Updated
2026-11-02
NVD 8.7

Multer is a node.js middleware for handling multipart/form-data. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Record
CVE-2026-3304
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-459
Updated
2026-11-02
OSV 8.7

Multer vulnerable to Denial of Service via incomplete cleanup

Multer is a node.js middleware for handling multipart/form-data. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Record
CVE-2026-3304
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-459
Updated
2026-11-02
OSVGHSA-xf7r-hgr6-v32p 8.7

Multer vulnerable to Denial of Service via incomplete cleanup

Impact

A vulnerability in Multer versions < 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion.

Patches

Users should upgrade to 2.1.0

Workarounds

None

Record
GHSA-xf7r-hgr6-v32p
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-459
Updated
2026-11-02
OSVROOT-APP-NPM-CVE-2026-3304 No score

CVE-2026-3304 in multer - Patched by Root

Root has patched CVE-2026-3304 in the multer package for Root:npm. Multiple fixed versions available.

Record
ROOT-APP-NPM-CVE-2026-3304
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
multer
npm
before 2.1.0
2.1.0
multer
Root:npm
before 1.4.4-lts.1-aikido.3
1.4.4-lts.1-aikido.31.4.5-lts.2-aikido.91.4.4-lts.1-aikido.41.4.4-aikido.21.4.2-aikido.12.0.2-aikido.41.4.5-lts.1-aikido.21.4.5-lts.1-aikido.32.0.2-aikido.52.0.2-aikido.61.4.4-aikido.31.4.4-lts.1-aikido.11.4.4-aikido.41.4.5-lts.1-aikido.11.4.4-lts.1-aikido.21.4.4-aikido.51.4.4-aikido.61.4.2-aikido.21.4.5-lts.2-aikido.82.0.2-aikido.7
@rootio/multer
Root:npm
before 1.4.4-lts.1-root.io.3
1.4.4-lts.1-root.io.31.4.5-lts.2-root.io.92.0.2-root.io.21.4.4-lts.1-root.io.41.4.4-root.io.21.4.4-root.io.11.4.2-root.io.12.0.2-root.io.41.4.5-lts.1-root.io.21.4.5-lts.1-root.io.32.0.2-root.io.52.0.2-root.io.61.4.4-root.io.31.4.4-lts.1-root.io.11.4.4-root.io.41.4.5-lts.1-root.io.11.4.4-lts.1-root.io.21.4.4-root.io.51.4.4-root.io.61.4.2-root.io.21.4.5-lts.2-root.io.82.0.2-root.io.7

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubMkway/CVE-2026-33042026-03-06

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-3304 is a high vulnerability (CVSS 8.7) in Expressjs Multer, published February 27, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in multer 2.1.0.

References

Show 7 moreShow less
MoveEnter Open