Every CVE Search/ Get API key

CVE-2026-33611

Insufficient validation of HTTPS and SVCB records

6.5 MediumFix available

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

0.42%Up 0.4 points since Apr 23, 2026
90%50%10%1%

What each source reports

CVE List Score used 6.5

Insufficient validation of HTTPS and SVCB records

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
CVE-2026-33611
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2026-24951 6.5

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
EUVD-2026-24951
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-vqqc-7rwf-3j3j 6.5

An operator allowed to use the REST API can cause the Authoritative server to produce invalid...

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
GHSA-vqqc-7rwf-3j3j
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 6.5

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
CVE-2026-33611
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSVALPINE-CVE-2026-33611 4.9

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
ALPINE-CVE-2026-33611
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 6.5

Insufficient validation of HTTPS and SVCB records

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
CVE-2026-33611
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2026-33611 4.9

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
DEBIAN-CVE-2026-33611
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-33611 6.5

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

Record
UBUNTU-CVE-2026-33611
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
CVSS 3.1
4.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pdns
Alpine:v3.23
before 5.0.4-r0
5.0.4-r0
pdns
Alpine:v3.24
before 5.0.4-r0
5.0.4-r0
pdns
Debian:12
All versions, plus listed versions
4.7.3-24.8.0-14.8.0-24.8.1-14.8.1-2
Show 37 moreShow less
4.8.2-14.8.2-24.8.3-14.8.3-24.8.3-34.8.3-44.9.0-14.9.0-24.9.1-14.9.1-24.9.1-34.9.2-14.9.2-24.9.3-14.9.3-24.9.3-34.9.4-14.9.4-24.9.7-15.0.0-15.0.0-25.0.1-15.0.2-15.0.3-15.0.4-15.0.5-15.0.5-25.0.5-35.0.5-45.1.0-15.1.1-15.1.1-25.1.1-35.1.2-15.1.3-15.1.4-15.1.5-1
None known
pdns
Debian:13
before 4.9.14-0+deb13u1, plus listed versions
4.9.7-1
4.9.14-0+deb13u1
pdns
Debian:14
before 5.0.4-1, plus listed versions
4.9.7-15.0.0-15.0.0-25.0.1-15.0.2-15.0.3-1
5.0.4-1
pdns
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.4.5-1build23.4.6-23.4.6-33.4.7-13.4.7-2
Show 5 moreShow less
4.0.0~alpha1-14.0.0~alpha2-24.0.0~alpha2-34.0.0~alpha2-3build14.0.0~alpha2-3ubuntu0.1~esm1
None known
pdns
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.0.4-24.0.4-2build14.0.5-14.1.0-14.1.0-24.1.0-2build14.1.1-14.1.1-1ubuntu0.1~esm1
None known
pdns
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
4.1.6-3build14.2.0-14.2.1-14.2.1-1build14.2.1-1build24.2.1-1ubuntu0.1~esm1
None known
pdns
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
4.4.1-1build14.4.1-34.4.1-44.5.2-1build14.5.3-14.5.3-1ubuntu0.1~esm1
None known
pdns
Ubuntu:24.04:LTS
All versions, plus listed versions
4.8.1-1build14.8.3-24.8.3-2build14.8.3-34.8.3-44.8.3-4build24.8.3-4build3
None known
pdns
Ubuntu:25.10
All versions, plus listed versions
4.9.4-24.9.7-14.9.7-1build25.0.0-2
None known
pdns
Ubuntu:26.10
All versions, plus listed versions
5.0.2-1build15.0.5-45.1.0-15.1.1-15.1.1-2
Show 4 moreShow less
5.1.1-35.1.2-15.1.3-15.1.4-1
None known
pdns
Ubuntu:26.04:LTS
All versions, plus listed versions
5.0.0-25.0.1-15.0.2-15.0.2-1build1
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-33611 is a medium vulnerability (CVSS 6.5) in Powerdns Authoritative, published April 22, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in pdns 5.0.4-r0.

References

Show 5 moreShow less
MoveEnter Open