Every CVE Search/ Get API key

CVE-2026-34092

Block UI elements in 'tools'-sidebar shows presence of an autoblocked IP

2.1 LowFix available

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
Passive

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.24%Up 0.2 points since May 12, 2026
90%50%10%1%

What each source reports

CVE List Score used 2.1

Block UI elements in 'tools'-sidebar shows presence of an autoblocked IP

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34092
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2026-29064 2.1

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
EUVD-2026-29064
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-rg4j-v2c4-8gfh 2.1

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation...

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
GHSA-rg4j-v2c4-8gfh
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
NVD 2.1

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34092
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Skin/Skin.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34092
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2026-34092 7.5

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Skin/Skin.Php. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
DEBIAN-CVE-2026-34092
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2026-34092 2.1

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Skin/Skin.Php. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
UBUNTU-CVE-2026-34092
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-8315-1 No score

mediawiki vulnerabilities

It was discovered that MediaWiki incorrectly handled group membership visibility in the OATHAuth extension. An authenticated attacker could use this issue to determine if other users had two-factor authentication enabled. (CVE-2026-34087)

It was discovered that MediaWiki incorrectly handled suppressed log entry titles in the RecentChanges list. An unauthenticated attacker could use this issue to view titles of deleted or suppressed pages that should be hidden. (CVE-2026-34088)

It was discovered that MediaWiki incorrectly handled resource loading timing information. An attacker could use this issue to determine if certain pages existed on a wiki. (CVE-2026-34092)

Record
USN-8315-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:12
before 1:1.39.17-1+deb12u2, plus listed versions
1:1.39.10-11:1.39.10-1~deb12u11:1.39.12-1~deb12u11:1.39.13-1~deb12u11:1.39.17-1~deb12u1
Show 10 moreShow less
1:1.39.2-11:1.39.4-11:1.39.4-1~deb12u11:1.39.4-21:1.39.5-11:1.39.5-1~deb12u11:1.39.6-11:1.39.7-11:1.39.7-1~deb12u11:1.39.8-1
1:1.39.17-1+deb12u2
mediawiki
Debian:13
before 1:1.43.8+dfsg-1~deb13u1, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-11:1.43.6+dfsg-1~deb13u11:1.43.6+dfsg-2
1:1.43.8+dfsg-1~deb13u1
mediawiki
Debian:14
before 1:1.43.8+dfsg-1, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-11:1.43.6+dfsg-1~deb13u11:1.43.6+dfsg-21:1.43.8+dfsg-1~deb13u1
1:1.43.8+dfsg-1
mediawiki
Ubuntu:Pro:24.04:LTS
before 1:1.39.7-1ubuntu0.1~esm1, plus listed versions
1:1.39.4-21:1.39.5-11:1.39.6-11:1.39.7-1
1:1.39.7-1ubuntu0.1~esm1
mediawiki
Ubuntu:25.10
All versions, plus listed versions
1:1.43.1+dfsg-11:1.43.1+dfsg-21:1.43.3+dfsg-1
None known
mediawiki
Ubuntu:26.10
before 1:1.43.8+dfsg-2
1:1.43.8+dfsg-2
mediawiki
Ubuntu:26.04:LTS
before 1:1.43.8+dfsg-2, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-21:1.43.8+dfsg-1
1:1.43.8+dfsg-2
mediawiki
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 1:1.31.7-1ubuntu0.1~esm1, plus listed versions
1:1.31.2-1ubuntu11:1.31.5-11:1.31.5-1ubuntu11:1.31.5-21:1.31.5-31:1.31.5-3ubuntu11:1.31.6-11:1.31.7-1
1:1.31.7-1ubuntu0.1~esm1
mediawiki
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 1:1.35.6-1ubuntu0.1~esm1, plus listed versions
1:1.35.3-11:1.35.4-11:1.35.5-11:1.35.5-1ubuntu11:1.35.5-1ubuntu21:1.35.5-1ubuntu31:1.35.6-1
1:1.35.6-1ubuntu0.1~esm1
mediawiki
Ubuntu:Pro:24.04:LTS
From an advisory covering 3 CVEs
before 1:1.39.7-1ubuntu0.1~esm1, plus listed versions
1:1.39.4-21:1.39.5-11:1.39.6-11:1.39.7-1
1:1.39.7-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-34092 is a low vulnerability (CVSS 2.1) in Mediawiki, published May 11, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.24%, the 14th percentile. Fixed in mediawiki 1:1.39.17-1+deb12u2.

References

Show 6 moreShow less
MoveEnter Open