Every CVE Search/ Get API key

CVE-2026-34094

Customized help link for page protection indicator is relative to subpage name, because the link target is missing the "/wiki/" prefix

2.0 LowFix available

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
Passive

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.17%Up 0.1 points since May 12, 2026
90%50%10%1%

What each source reports

CVE List Score used 2.0

Customized help link for page protection indicator is relative to subpage name, because the link target is missing the "/wiki/" prefix

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34094
CVSS 4.0
2.0 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-668
Updated
2026-11-02
EUVDEUVD-2026-29108 2.0

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
EUVD-2026-29108
CVSS 4.0
2.0 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-g863-m67x-whh5 2.0

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program...

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
GHSA-g863-m67x-whh5
CVSS 4.0
2.0 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
3.8 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-668
Updated
2026-11-02
NVD 2.0

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34094
CVSS 4.0
2.0 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
3.8 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-668
Updated
2026-11-02
OSV 3.8

Vulnerability in Wikimedia Foundation MediaWiki.

This vulnerability is associated with program files includes/Page/Article.Php.

This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
CVE-2026-34094
CVSS 3.1
3.8 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2026-34094 3.8

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Page/Article.Php. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
DEBIAN-CVE-2026-34094
CVSS 3.1
3.8 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2026-34094 2.0

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/Page/Article.Php. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.

Record
UBUNTU-CVE-2026-34094
CVSS 4.0
2.0 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
3.8 LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Debian:13
before 1:1.43.8+dfsg-1~deb13u1, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-11:1.43.6+dfsg-1~deb13u11:1.43.6+dfsg-2
1:1.43.8+dfsg-1~deb13u1
mediawiki
Debian:14
before 1:1.43.8+dfsg-1, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-11:1.43.6+dfsg-1~deb13u11:1.43.6+dfsg-21:1.43.8+dfsg-1~deb13u1
1:1.43.8+dfsg-1
mediawiki
Ubuntu:18.04:LTS
All versions, plus listed versions
1:1.27.3-11:1.27.4-11:1.27.4-21:1.27.4-3
None known
mediawiki
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1:1.31.2-1ubuntu11:1.31.5-11:1.31.5-1ubuntu11:1.31.5-21:1.31.5-3
Show 4 moreShow less
1:1.31.5-3ubuntu11:1.31.6-11:1.31.7-11:1.31.7-1ubuntu0.1~esm1
None known
mediawiki
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1:1.35.3-11:1.35.4-11:1.35.5-11:1.35.5-1ubuntu11:1.35.5-1ubuntu21:1.35.5-1ubuntu31:1.35.6-11:1.35.6-1ubuntu0.1~esm1
None known
mediawiki
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
1:1.39.4-21:1.39.5-11:1.39.6-11:1.39.7-11:1.39.7-1ubuntu0.1~esm1
None known
mediawiki
Ubuntu:25.10
All versions, plus listed versions
1:1.43.1+dfsg-11:1.43.1+dfsg-21:1.43.3+dfsg-1
None known
mediawiki
Ubuntu:26.10
All versions, plus listed versions
1:1.43.8+dfsg-21:1.43.9+dfsg-11:1.43.9+dfsg-1ubuntu1
None known
mediawiki
Ubuntu:26.04:LTS
All versions, plus listed versions
1:1.43.3+dfsg-11:1.43.5+dfsg-11:1.43.6+dfsg-21:1.43.8+dfsg-11:1.43.8+dfsg-2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-34094 is a low vulnerability (CVSS 2.0) in Mediawiki, published May 11, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.17%, the 6th percentile. Fixed in mediawiki 1:1.43.8+dfsg-1~deb13u1.

References

MoveEnter Open