Every CVE Search/ Get API key

CVE-2026-3650

Grassroots DICOM Missing release of memory after effective lifetime

8.7 HighFix available

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.36%Up 0.3 points since Mar 27, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.7

Grassroots DICOM Missing release of memory after effective lifetime

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
CVE-2026-3650
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
EUVDEUVD-2026-16450 8.7

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
EUVD-2026-16450
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-42p8-rv8p-8h4j 8.7

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing...

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
GHSA-42p8-rv8p-8h4j
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
NVD 8.7

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
CVE-2026-3650
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
OSVDEBIAN-CVE-2026-3650 8.7

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
DEBIAN-CVE-2026-3650
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-3650 8.7

A memory leak exists in the Grassroots DICOM library (GDCM). The bug occurs when parsing malformed DICOM files with non-standard VR types in file meta information. The vulnerability leads to vast memory allocations and resource depletion, triggering a denial-of-service condition. A maliciously crafted file can fill the heap in a single read operation without properly releasing it.

Record
UBUNTU-CVE-2026-3650
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2026:11701-1 No score

insighttoolkit-devel-5.4.7-1.1 on GA media

These are all security issues fixed in the insighttoolkit-devel-5.4.7-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11701-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gdcm
Debian:12
All versions, plus listed versions
3.0.21-13.0.21-23.0.22-13.0.22-23.0.22-2.1
Show 20 moreShow less
3.0.22-2.1~exp13.0.22-33.0.24-13.0.24-1+hurd.13.0.24-103.0.24-113.0.24-123.0.24-133.0.24-143.0.24-23.0.24-33.0.24-3+hurd.13.0.24-43.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9
None known
gdcm
Debian:13
All versions, plus listed versions
3.0.24-103.0.24-113.0.24-123.0.24-133.0.24-14
Show 7 moreShow less
3.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9
None known
gdcm
Debian:14
before 3.0.24-11, plus listed versions
3.0.24-103.0.24-53.0.24-5+hurd.13.0.24-5+hurd.23.0.24-63.0.24-73.0.24-83.0.24-9
3.0.24-11
gdcm
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
2.2.3-2ubuntu32.2.3-2ubuntu42.2.4-1.1ubuntu12.2.4-1.1ubuntu22.2.4-1.1ubuntu32.2.4-1.1ubuntu42.2.4-1.1ubuntu4+esm1
None known
gdcm
Ubuntu:16.04:LTS
All versions, plus listed versions
2.4.4-42.4.4-4build12.4.4-4ubuntu12.6.1-32.6.2-1
Show 7 moreShow less
2.6.2-22.6.2-32.6.3-12.6.3-1ubuntu12.6.3-2ubuntu12.6.3-3ubuntu12.6.3-3ubuntu3
None known
gdcm
Ubuntu:18.04:LTS
All versions, plus listed versions
2.8.2-3build12.8.3-12.8.4-12.8.4-1build2
None known
gdcm
Ubuntu:20.04:LTS
All versions, plus listed versions
2.8.8-9ubuntu42.8.8-9ubuntu53.0.4-23.0.4-2build13.0.4-2ubuntu13.0.5-1ubuntu13.0.5-1.1ubuntu13.0.5-1.1ubuntu2
None known
gdcm
Ubuntu:22.04:LTS
All versions, plus listed versions
3.0.8-23.0.10-13.0.10-1build2
None known
gdcm
Ubuntu:24.04:LTS
All versions, plus listed versions
3.0.21-23.0.22-13.0.22-2build13.0.22-2build23.0.22-2.1build13.0.22-2.1build23.0.22-2.1ubuntu1
None known
gdcm
Ubuntu:25.10
All versions, plus listed versions
3.0.24-5ubuntu23.0.24-5ubuntu3
None known
gdcm
Ubuntu:26.10
All versions, plus listed versions
3.0.24-9ubuntu13.0.24-103.0.24-113.0.24-12ubuntu13.0.24-14
None known
gdcm
Ubuntu:26.04:LTS
All versions, plus listed versions
3.0.24-5ubuntu33.0.24-7ubuntu13.0.24-93.0.24-9ubuntu1
None known
insighttoolkit
openSUSE:Tumbleweed
before 5.4.7-1.1
5.4.7-1.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-3650 is a high vulnerability (CVSS 8.7) in Grassroots Dicom (gdcm), published March 26, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in gdcm 3.0.24-11.

References

Show 4 moreShow less
MoveEnter Open