CVE-2026-39043
gst-plugins-good1.0 vulnerabilities
Heap buffer overflow in Matroska demuxer
What each source reports
OSVUBUNTU-CVE-2026-39043 No score
Heap buffer overflow in Matroska demuxer
- Record
UBUNTU-CVE-2026-39043- Updated
- 2026-11-02
OSVUSN-8584-1 No score
gst-plugins-good1.0 vulnerabilities
It was discovered that GStreamer Good Plugins incorrectly handled certain Matroska files. An attacker could possibly use this issue to cause GStreamer Good Plugins to crash, resulting in a denial of service. This issue only affected Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2026-39043)
It was discovered that GStreamer Good Plugins incorrectly handled certain WAV files. An attacker could possibly use this issue to cause GStreamer Good Plugins to crash, resulting in a denial of service. This issue only affected Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2026-39044)
It was discovered that GStreamer Good Plugins incorrectly handled certain WavPack audio files. An attacker could use this issue to cause GStreamer Good Plugins to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2026-53705)
- Record
USN-8584-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gst-plugins-good1.0Debian:12 |
before 1.22.0-5+deb12u4, plus listed versions 1.22.0-51.22.0-5+deb12u11.22.0-5+deb12u21.22.0-5+deb12u3 |
1.22.0-5+deb12u4 |
gst-plugins-good1.0Debian:13 |
before 1.26.2-1+deb13u2, plus listed versions 1.26.2-11.26.2-1+deb13u1 |
1.26.2-1+deb13u2 |
gst-plugins-good1.0Debian:14 |
before 1.28.2-1, plus listed versions 1.26.10-11.26.2-11.26.3-11.26.4-11.26.5-1 Show 14 moreShow less1.26.5-21.26.5-2+hurd.11.26.5-31.26.6-11.26.7-11.26.8-11.26.9-11.27.1-11.27.2-11.27.50-11.27.50-21.27.90-11.28.0-11.28.1-1 |
1.28.2-1 |
gst-plugins-good1.0Ubuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.6.0-1ubuntu11.6.1-1ubuntu11.6.2-1ubuntu11.7.1-1ubuntu11.7.2-1ubuntu1 Show 14 moreShow less1.7.90-1ubuntu11.7.91-1ubuntu11.8.0-1ubuntu11.8.1-1ubuntu0.11.8.2-1ubuntu0.11.8.2-1ubuntu0.21.8.2-1ubuntu0.31.8.3-1ubuntu0.31.8.3-1ubuntu0.41.8.3-1ubuntu0.51.8.3-1ubuntu0.5+esm11.8.3-1ubuntu0.5+esm21.8.3-1ubuntu0.5+esm31.8.3-1ubuntu0.5+esm4 |
None known |
gst-plugins-good1.0Ubuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.12.3-1ubuntu11.12.4-1ubuntu11.13.1-1ubuntu11.13.91-1ubuntu11.14.0-1ubuntu1 Show 9 moreShow less1.14.1-1ubuntu1~ubuntu18.04.11.14.4-1ubuntu1~ubuntu18.04.11.14.5-0ubuntu1~18.04.11.14.5-0ubuntu1~18.04.21.14.5-0ubuntu1~18.04.31.14.5-0ubuntu1~18.04.3+esm11.14.5-0ubuntu1~18.04.3+esm21.14.5-0ubuntu1~18.04.3+esm31.14.5-0ubuntu1~18.04.3+esm4 |
None known |
gst-plugins-good1.0Ubuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.16.1-1ubuntu11.16.2-1ubuntu11.16.2-1ubuntu21.16.2-1ubuntu2.11.16.3-0ubuntu1 Show 7 moreShow less1.16.3-0ubuntu1.11.16.3-0ubuntu1.21.16.3-0ubuntu1.31.16.3-0ubuntu1.3+esm11.16.3-0ubuntu1.3+esm21.16.3-0ubuntu1.3+esm31.16.3-0ubuntu1.3+esm4 |
None known |
gst-plugins-good1.0Ubuntu:22.04:LTS |
before 1.20.3-0ubuntu1.7, plus listed versions 1.18.5-1ubuntu21.18.5-1ubuntu31.20.0-2ubuntu11.20.1-1ubuntu11.20.3-0ubuntu1 Show 5 moreShow less1.20.3-0ubuntu1.11.20.3-0ubuntu1.31.20.3-0ubuntu1.41.20.3-0ubuntu1.51.20.3-0ubuntu1.6 |
1.20.3-0ubuntu1.7 |
gst-plugins-good1.0Ubuntu:24.04:LTS |
before 1.24.2-1ubuntu1.5, plus listed versions 1.22.6-1ubuntu11.22.6-1ubuntu21.22.8-3ubuntu11.22.9-1ubuntu11.24.0-1ubuntu5 Show 7 moreShow less1.24.0-1ubuntu71.24.1-2ubuntu11.24.2-1ubuntu11.24.2-1ubuntu1.11.24.2-1ubuntu1.21.24.2-1ubuntu1.31.24.2-1ubuntu1.4 |
1.24.2-1ubuntu1.5 |
gst-plugins-good1.0Ubuntu:25.10 |
All versions, plus listed versions 1.26.0-1ubuntu21.26.0-1ubuntu31.26.2-1ubuntu11.26.4-1ubuntu11.26.5-1ubuntu1 Show 4 moreShow less1.26.5-1ubuntu21.26.5-1ubuntu2.11.26.5-1ubuntu2.21.26.5-1ubuntu2.3 |
None known |
gst-plugins-good1.0Ubuntu:22.04:LTS From an advisory covering 3 CVEs |
before 1.20.3-0ubuntu1.7, plus listed versions 1.18.5-1ubuntu21.18.5-1ubuntu31.20.0-2ubuntu11.20.1-1ubuntu11.20.3-0ubuntu1 Show 5 moreShow less1.20.3-0ubuntu1.11.20.3-0ubuntu1.31.20.3-0ubuntu1.41.20.3-0ubuntu1.51.20.3-0ubuntu1.6 |
1.20.3-0ubuntu1.7 |
gst-plugins-good1.0Ubuntu:24.04:LTS From an advisory covering 3 CVEs |
before 1.24.2-1ubuntu1.5, plus listed versions 1.22.6-1ubuntu11.22.6-1ubuntu21.22.8-3ubuntu11.22.9-1ubuntu11.24.0-1ubuntu5 Show 7 moreShow less1.24.0-1ubuntu71.24.1-2ubuntu11.24.2-1ubuntu11.24.2-1ubuntu1.11.24.2-1ubuntu1.21.24.2-1ubuntu1.31.24.2-1ubuntu1.4 |
1.24.2-1ubuntu1.5 |
gst-plugins-good1.0Ubuntu:26.04:LTS From an advisory covering 3 CVEs |
before 1.28.2-2ubuntu0.1, plus listed versions 1.26.5-1ubuntu21.27.2-1ubuntu11.27.90-1ubuntu11.28.0-1ubuntu11.28.0-1ubuntu31.28.1-1ubuntu11.28.2-2 |
1.28.2-2ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-39043 is a vulnerability with no CVSS score yet in gst-plugins-good1.0, published June 16, 2026. No source lists public exploit code. Fixed in gst-plugins-good1.0 1.22.0-5+deb12u4.