CVE-2026-39938
Cacti: Unauthenticated RCE on Graph Image
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Cacti: Unauthenticated RCE on Graph Image
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
CVE-2026-39938- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2026-39136
9.8
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
EUVD-2026-39136- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
NVD
9.8
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
CVE-2026-39938- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-78
- Updated
- 2026-11-02
OSV
9.8
Cacti: Unauthenticated RCE on Graph Image
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
CVE-2026-39938- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-78
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-39938
9.8
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
DEBIAN-CVE-2026-39938- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-39938
9.8
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have unauthenticated LFI through graph_theme and rrdtool IPC serialization hardening. This issue has been resolved in version 1.2.31.
- Record
UBUNTU-CVE-2026-39938- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-04
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cactiDebian:12 |
All versions, plus listed versions 1.2.24+ds1-11.2.24+ds1-1+deb12u11.2.24+ds1-1+deb12u21.2.24+ds1-1+deb12u31.2.24+ds1-1+deb12u4 Show 17 moreShow less1.2.24+ds1-1+deb12u51.2.25+ds1-11.2.25+ds1-21.2.26+ds1-11.2.27+ds1-11.2.27+ds1-21.2.28+ds1-11.2.28+ds1-21.2.28+ds1-31.2.28+ds1-41.2.30+ds1-11.2.30+ds1-21.2.30+ds1-31.2.31+ds1-11.2.31+ds1-21.2.31+ds1-31.2.31+ds1-4 |
None known |
cactiDebian:13 |
All versions, plus listed versions 1.2.30+ds1-11.2.30+ds1-21.2.30+ds1-31.2.31+ds1-11.2.31+ds1-21.2.31+ds1-31.2.31+ds1-4 |
None known |
cactiDebian:14 |
before 1.2.31+ds1-1, plus listed versions 1.2.30+ds1-11.2.30+ds1-21.2.30+ds1-3 |
1.2.31+ds1-1 |
cactiUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.1.18+ds1-11.1.27+ds1-21.1.27+ds1-31.1.28+ds1-21.1.35+ds1-1 Show 5 moreShow less1.1.36+ds1-11.1.38+ds1-11.1.38+ds1-1ubuntu0.1~esm11.1.38+ds1-1ubuntu0.1~esm31.1.38+ds1-1ubuntu0.1~esm4 |
None known |
cactiUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1.2.4+ds1-2ubuntu31.2.9+ds1-1ubuntu11.2.9+ds1-1ubuntu21.2.10+ds1-1ubuntu11.2.10+ds1-1ubuntu1+esm11.2.10+ds1-1ubuntu1.11.2.10+ds1-1ubuntu1.1+esm11.2.10+ds1-1ubuntu1.1+esm2 |
None known |
cactiUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1.2.16+ds1-2ubuntu11.2.19+ds1-2ubuntu11.2.19+ds1-2ubuntu1+esm11.2.19+ds1-2ubuntu1.11.2.19+ds1-2ubuntu1.1+esm11.2.19+ds1-2ubuntu1.1+esm2 |
None known |
cactiUbuntu:24.04:LTS |
All versions, plus listed versions 1.2.25+ds1-21.2.26+ds1-11.2.26+ds1-1ubuntu0.1 |
None known |
cactiUbuntu:25.10 |
All versions, plus listed versions 1.2.28+ds1-4ubuntu11.2.30+ds1-1ubuntu1 |
None known |
cactiUbuntu:26.10 |
All versions, plus listed versions 1.2.30+ds1-1ubuntu21.2.30+ds1-1ubuntu31.2.31+ds1-3ubuntu2 |
None known |
cactiUbuntu:26.04:LTS |
All versions, plus listed versions 1.2.30+ds1-1ubuntu11.2.30+ds1-1ubuntu2 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | kx00007/CVE-2026-39938 | 2026-04-04 |
| PoC in GitHub | Polosss/By-Poloss..-..CVE-2026-39938 | 2026-06-26 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, exploits, facts | OSV | |
| first indexed | CVE List, EUVD, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-39938 is a critical vulnerability (CVSS 9.8) in Cacti, published June 24, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 53rd percentile. Fixed in cacti 1.2.31+ds1-1.
References
github.com/Cacti/cacti/security/advisories/GHSA-rm7p-qcqm-x5m6
github.com/Cacti/cacti/commit/9871f0cef9af285398d558c9b3188d5977e01a04
github.com/CVEProject/cvelistV5/tree/main/cves/2026/39xxx/CVE-2026-39938.json
nvd.nist.gov/vuln/detail/CVE-2026-39938
security-tracker.debian.org/tracker/CVE-2026-39938
ubuntu.com/security/CVE-2026-39938
cve.org/CVERecord?id=CVE-2026-39938