CVE-2026-41682
pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.9
pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
CVE-2026-41682- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-195, CWE-918
- Updated
- 2026-11-02
EUVDEUVD-2026-28846
6.9
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
EUVD-2026-28846- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Updated
- 2026-11-02
NVD
6.9
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
CVE-2026-41682- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-195, CWE-918
- Updated
- 2026-11-02
OSV
6.9
pupnp: Port truncation via atoi() cast in parse_uri() allows SSRF port confusion
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
CVE-2026-41682- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-195, CWE-918
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-41682
6.9
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
DEBIAN-CVE-2026-41682- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-41682
6.9
pupnp is an SDK for development of UPnP device and control point applications. Prior to version 1.18.5, pupnp is vulnerable to SRRF port confusion due to port truncation via atoi() cast in parse_uri(). This issue has been patched in version 1.18.5.
- Record
UBUNTU-CVE-2026-41682- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Updated
- 2026-11-02
OSVMGASA-2026-0223 No score
Updated libupnp packages fix security vulnerability
Port truncation via atoi() cast in parse_uri() allows SSRF port confusion. (CVE-2026-41682)
- Record
MGASA-2026-0223- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:10641-1 No score
libixml11-1.18.5-1.1 on GA media
These are all security issues fixed in the libixml11-1.18.5-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:10641-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pupnpDebian:13 |
before 1:1.14.20-1+deb13u1, plus listed versions 1:1.14.20-1 |
1:1.14.20-1+deb13u1 |
pupnpDebian:14 |
before 1:1.14.31-1, plus listed versions 1:1.14.20-11:1.14.23-11:1.14.24-11:1.14.24-21:1.14.24-31:1.14.25-1 |
1:1.14.31-1 |
libupnpMageia:9 |
before 1.14.17-1.1.mga9 | 1.14.17-1.1.mga9 |
libupnpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:1.6.19+git20141001-11:1.6.19+git20141001-1ubuntu11:1.6.19+git20160116-11:1.6.19+git20160116-1ubuntu0.1~esm1 |
None known |
mediatombUbuntu:16.04:LTS |
All versions, plus listed versions 0.12.1-47-g7ab7616-1ubuntu10.12.1-47-g7ab7616-1ubuntu2 |
None known |
libupnpUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.6.22-11:1.6.24-11:1.6.24-21:1.6.24-31:1.6.24-4 |
None known |
pupnp-1.8Ubuntu:18.04:LTS |
All versions, plus listed versions 1:1.8.2-21:1.8.2-3 |
None known |
pupnp-1.8Ubuntu:20.04:LTS |
All versions, plus listed versions 1:1.8.4-2ubuntu2 |
None known |
pupnp-1.8Ubuntu:22.04:LTS |
All versions, plus listed versions 1:1.8.4-2ubuntu2 |
None known |
pupnpUbuntu:24.04:LTS |
All versions, plus listed versions 1:1.14.18-1ubuntu11:1.14.18-1.1ubuntu11:1.14.18-1.1ubuntu2 |
None known |
Show 4 moreShow less
| Package | Affected | Fixed |
|---|---|---|
pupnpUbuntu:25.10 |
All versions, plus listed versions 1:1.14.20-1ubuntu11:1.14.24-2ubuntu11:1.14.24-3ubuntu1 |
None known |
pupnpUbuntu:26.10 |
All versions, plus listed versions 1:1.14.25-1ubuntu11:1.14.31-1ubuntu11:1.14.31-1ubuntu2 |
None known |
pupnpUbuntu:26.04:LTS |
All versions, plus listed versions 1:1.14.24-3ubuntu11:1.14.25-1ubuntu1 |
None known |
libupnpopenSUSE:Tumbleweed |
before 1.18.5-1.1 | 1.18.5-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-41682 is a medium vulnerability (CVSS 6.9) in Pupnp, published April 28, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in pupnp 1:1.14.20-1+deb13u1.
References
github.com/pupnp/pupnp/security/advisories/GHSA-q522-6w45-4j58
github.com/pupnp/pupnp/commit/def5f9a2bc42f5b3d713e37c516fbe840ce54b7b
github.com/pupnp/pupnp/releases/tag/release-1.18.5
github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41682.json
nvd.nist.gov/vuln/detail/CVE-2026-41682
security-tracker.debian.org/tracker/CVE-2026-41682
Show 7 moreShow less
advisories.mageia.org/MGASA-2026-0223.html
bugs.mageia.org/show_bug.cgi?id=35462
lists.opensuse.org/archives/list/[email protected]/message/RGEL3TKVF7UPJUO7JGIIJKNEXLRIV6PS
ubuntu.com/security/CVE-2026-41682
cve.org/CVERecord?id=CVE-2026-41682
github.com/pupnp/pupnp/commit/58021a7600876c77403e2e06eb19d21efc196d21
suse.com/security/cve/CVE-2026-41682