Every CVE Search/ Get API key

CVE-2026-41990

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds...

4.0 MediumFix available

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
Low

Exploit likelihood

0.23%Up 0.2 points since Apr 23, 2026
90%50%10%1%

What each source reports

CVE List Score used 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2026-25193 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
EUVD-2026-25193
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-78pv-qq8x-94px 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds...

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
GHSA-78pv-qq8x-94px
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
NVD 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
OSVBELL-CVE-2026-41990 4.0
Record
BELL-CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
OSV 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-787
Updated
2026-11-02
Show 8 moreShow less
OSVDEBIAN-CVE-2026-41990 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
DEBIAN-CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
OSVJLSEC-2026-497 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
JLSEC-2026-497
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
OSVRHSA-2026:8466 7.5

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Record
RHSA-2026:8466
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-41990 4.0

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

Record
UBUNTU-CVE-2026-41990
CVSS 3.1
4.0 MediumCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2026:21047-1 No score

Security update for libgcrypt

This update for libgcrypt fixes the following issue

  • CVE-2026-41990: lack of bound check can lead to mishandling of Dilithium signing (bsc#1262693).
Record
openSUSE-SU-2026:21047-1
Updated
2026-11-02
OSVSUSE-SU-2026:22270-1 No score

Security update for libgcrypt

This update for libgcrypt fixes the following issue

  • CVE-2026-41990: lack of bound check can lead to mishandling of Dilithium signing (bsc#1262693).
Record
SUSE-SU-2026:22270-1
Updated
2026-11-02
OSVSUSE-SU-2026:22355-1 No score

Security update for libgcrypt

This update for libgcrypt fixes the following issue

  • CVE-2026-41990: lack of bound check can lead to mishandling of Dilithium signing (bsc#1262693).
Record
SUSE-SU-2026:22355-1
Updated
2026-11-02
OSVUSN-8319-1 No score

libgcrypt20 vulnerabilities

It was discovered that Libgcrypt incorrectly handled crafted ECDH ciphertext. An attacker could possibly use this issue to cause Libgcrypt to crash, resulting in a denial of service. (CVE-2026-41989)

It was discovered that Libgcrypt incorrectly handled Dilithium signing. An attacker could possibly use this issue to cause Libgcrypt to crash, resulting in a denial of service. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-41990)

Record
USN-8319-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libgcrypt
Alpaquita:stream
1.12.0-r0 up to 1.12.2-r0
1.12.2-r0
libgcrypt20
Debian:14
before 1.12.2-1, plus listed versions
1.11.0+git20250114-11.11.0-71.11.1-11.11.2-11.11.2-2
Show 5 moreShow less
1.11.2-31.12.0-11.12.0-21.12.1-11.12.1-2
1.12.2-1
Libgcrypt_jll
Julia
1.12.0+0 up to 1.12.2+0
1.12.2+0
libgcrypt
Red Hat:hummingbird:1
before 0:1.12.2-1.hum1
0:1.12.2-1.hum1
libgcrypt-devel
Red Hat:hummingbird:1
before 0:1.12.2-1.hum1
0:1.12.2-1.hum1
libgcrypt
SUSE:Linux Micro 6.2
before 1.12.1-160000.2.1
1.12.1-160000.2.1
libgcrypt
SUSE:Linux Enterprise Server 16.0
before 1.12.1-160000.2.1
1.12.1-160000.2.1
libgcrypt
SUSE:Linux Enterprise Server for SAP applications 16.0
before 1.12.1-160000.2.1
1.12.1-160000.2.1
libgcrypt20
Ubuntu:Pro:FIPS-updates:24.04:LTS
before 1.12.0-2ubuntu0.1~Fips1~rc11, plus listed versions
1.10.3-2ubuntu0.1~Fips1~rc61.10.3-2ubuntu0.1~Fips1~rc7
1.12.0-2ubuntu0.1~Fips1~rc11
libgcrypt20
Ubuntu:26.04:LTS
before 1.12.0-2ubuntu0.1, plus listed versions
1.11.0-7build11.11.2-21.11.2-31.12.0-2
1.12.0-2ubuntu0.1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
libgcrypt20
Ubuntu:22.04:LTS
before 1.9.4-3ubuntu3.2, plus listed versions
1.8.7-5ubuntu21.9.4-3ubuntu21.9.4-3ubuntu3
1.9.4-3ubuntu3.2
libgcrypt20
Ubuntu:24.04:LTS
before 1.10.3-2ubuntu0.1, plus listed versions
1.10.2-3ubuntu11.10.3-21.10.3-2build1
1.10.3-2ubuntu0.1
libgcrypt20
Ubuntu:25.10
before 1.11.0-7ubuntu0.1, plus listed versions
1.11.0-6ubuntu11.11.0-71.11.0-7build1
1.11.0-7ubuntu0.1
libgcrypt
openSUSE:Leap 16.0
before 1.12.1-160000.2.1
1.12.1-160000.2.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-41990 is a medium vulnerability (CVSS 4.0) in Gnupg Libgcrypt, published April 23, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in libgcrypt 1.12.2-r0.

References

Show 21 moreShow less
MoveEnter Open