Every CVE Search/ Get API key

CVE-2026-42171

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp...

7.8 HighFix available

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.21%Up 0.2 points since Apr 25, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
CVE-2026-42171
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-427
Updated
2026-11-02
EUVDEUVD-2026-25637 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
EUVD-2026-25637
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-594m-24qw-wfmp 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp...

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
GHSA-594m-24qw-wfmp
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-427
Updated
2026-11-02
NVD 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
CVE-2026-42171
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-427
Updated
2026-11-02
OSV 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
CVE-2026-42171
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-427
Updated
2026-11-02
OSVDEBIAN-CVE-2026-42171 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
DEBIAN-CVE-2026-42171
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-42171 7.8

NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).

Record
UBUNTU-CVE-2026-42171
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nsis
Debian:12
All versions, plus listed versions
3.08-33.08-3+deb12u13.09-13.09-23.09-3
Show 5 moreShow less
3.09-43.10-13.10-23.11-13.12-1
None known
nsis
Debian:13
All versions, plus listed versions
3.11-13.12-1
None known
nsis
Debian:14
before 3.12-1, plus listed versions
3.11-1
3.12-1
nsis
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
2.46-72.46-7ubuntu0.1~esm1
None known
nsis
Ubuntu:16.04:LTS
All versions, plus listed versions
2.46-10.12.48-22.50-1
None known
nsis
Ubuntu:18.04:LTS
All versions, plus listed versions
2.51-1
None known
nsis
Ubuntu:20.04:LTS
All versions, plus listed versions
3.04-13.04-23.05-13.05-2
None known
nsis
Ubuntu:22.04:LTS
All versions, plus listed versions
3.06.1-13.08-13.08-2
None known
nsis
Ubuntu:24.04:LTS
All versions, plus listed versions
3.09-13.09-23.09-33.09-43.09-4ubuntu1
None known
nsis
Ubuntu:25.10
All versions, plus listed versions
3.10-2ubuntu1
None known
nsis
Ubuntu:26.10
All versions, plus listed versions
3.10-2ubuntu2
None known
nsis
Ubuntu:26.04:LTS
All versions, plus listed versions
3.10-2ubuntu13.10-2ubuntu2
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-42171 is a high vulnerability (CVSS 7.8) in Nullsoft Scriptable Install System, published April 24, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.21%, the 11th percentile. Fixed in nsis 3.12-1.

References

Show 4 moreShow less
MoveEnter Open