CVE-2026-42268
ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.2
ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
CVE-2026-42268- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-191, CWE-248
- Updated
- 2026-11-02
EUVDEUVD-2026-29854
8.2
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
EUVD-2026-29854- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
NVD
8.2
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
CVE-2026-42268- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-191, CWE-248
- Updated
- 2026-11-02
OSV
8.2
ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
CVE-2026-42268- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-191, CWE-248
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-42268
7.5
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
DEBIAN-CVE-2026-42268- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-42268
8.2
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
UBUNTU-CVE-2026-42268- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-modsecurity-2026-42268 No score
ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
BIT-modsecurity-2026-42268- Updated
- 2026-11-02
OSVBIT-modsecurity2-2026-42268 No score
ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.
- Record
BIT-modsecurity2-2026-42268- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:10732-1 No score
libmodsecurity3-3.0.15-1.1 on GA media
These are all security issues fixed in the libmodsecurity3-3.0.15-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:10732-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
modsecurityBitnami |
3.0.0 up to 3.0.15 | 3.0.15 |
modsecurity2Bitnami |
3.0.0 up to 3.0.15 | 3.0.15 |
modsecurityDebian:12 |
before 3.0.9-1+deb12u2, plus listed versions 3.0.9-13.0.9-1+deb12u1 |
3.0.9-1+deb12u2 |
modsecurityDebian:13 |
before 3.0.14-1+deb13u1, plus listed versions 3.0.14-1 |
3.0.14-1+deb13u1 |
modsecurityDebian:14 |
before 3.0.15-1, plus listed versions 3.0.14-1 |
3.0.15-1 |
modsecurityUbuntu:20.04:LTS |
All versions, plus listed versions 3.0.3-13.0.4-13.0.4-1build1 |
None known |
modsecurityUbuntu:22.04:LTS |
All versions, plus listed versions 3.0.4-23.0.6-1 |
None known |
modsecurityUbuntu:24.04:LTS |
All versions, plus listed versions 3.0.10-13.0.11-13.0.12-13.0.12-1.1build13.0.12-1.1build2 |
None known |
modsecurityUbuntu:25.10 |
All versions, plus listed versions 3.0.13-13.0.14-13.0.14-1build1 |
None known |
modsecurityUbuntu:26.10 |
All versions, plus listed versions 3.0.14-1build23.0.15-13.0.16-1 |
None known |
modsecurityUbuntu:26.04:LTS |
All versions, plus listed versions 3.0.14-1build13.0.14-1build2 |
None known |
modsecurityopenSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 3.0.15-1.1 | 3.0.15-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-42268 is a high vulnerability (CVSS 8.2) in Owasp Modsecurity, published May 8, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 33rd percentile. Fixed in modsecurity 3.0.15.
References
github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vwr3-7x7g-7p9w
nvd.nist.gov/vuln/detail/CVE-2026-42268
github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42268.json
security-tracker.debian.org/tracker/CVE-2026-42268
ubuntu.com/security/CVE-2026-42268
cve.org/CVERecord?id=CVE-2026-42268
suse.com/security/cve/CVE-2026-30923
suse.com/security/cve/CVE-2026-42268