Every CVE Search/ Get API key

CVE-2026-42509

Apache Wicket: crafted strings can break out of the JavaScript sequence

6.1 MediumFix available

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.36%Up 0.3 points since May 6, 2026
90%50%10%1%

What each source reports

NVD Score used 6.1

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
CVE-2026-42509
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List 6.1

Apache Wicket: crafted strings can break out of the JavaScript sequence

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
CVE-2026-42509
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2026-27556 6.1

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
EUVD-2026-27556
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-5x9h-93gp-chpj 6.1

Apache Wicket has a Cross-site Scripting issue

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
GHSA-5x9h-93gp-chpj
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Apache Wicket: crafted strings can break out of the JavaScript sequence

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
CVE-2026-42509
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-5x9h-93gp-chpj 6.1

Apache Wicket has a Cross-site Scripting issue

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Record
GHSA-5x9h-93gp-chpj
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.wicket:wicket-parent
Maven
8.0.0-M1 to 8.17.0 None known
org.apache.wicket:wicket-parent
Maven
9.0.0-M1 to 9.22.0 None known
org.apache.wicket:wicket-parent
Maven
10.0.0-M1 to 10.8.0
10.9.0
org.apache.wicket:wicket-parent
Maven
8.0.0-M1 to 8.17.0, plus listed versions
8.0.08.0.0-M28.0.0-M38.0.0-M48.0.0-M5
Show 21 moreShow less
8.0.0-M68.0.0-M78.0.0-M88.0.0-M98.1.08.10.08.11.08.12.08.13.08.14.08.15.08.16.08.2.08.3.08.4.08.5.08.6.08.6.18.7.08.8.08.9.0
None known
org.apache.wicket:wicket-parent
Maven
9.0.0-M1 to 9.22.0, plus listed versions
9.0.09.0.0-M29.0.0-M39.0.0-M49.0.0-M5
Show 22 moreShow less
9.1.09.10.09.11.09.12.09.13.09.14.09.15.09.16.09.17.09.18.09.19.09.2.09.20.09.21.09.3.09.4.09.5.09.6.09.7.09.8.09.9.09.9.1
None known
org.apache.wicket:wicket-parent
Maven
10.0.0-M1 up to 10.9.0, plus listed versions
10.0.010.0.0-M210.1.010.2.010.3.0
Show 5 moreShow less
10.4.010.5.010.6.010.7.010.8.0
10.9.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-42509 is a medium vulnerability (CVSS 6.1) in Apache Wicket, published May 6, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in org.apache.wicket:wicket-parent 10.9.0.

References

MoveEnter Open