CVE-2026-42510
OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.6
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
CVE-2026-42510- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-829
- Updated
- 2026-11-02
EUVDEUVD-2026-25982
6.6
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
EUVD-2026-25982- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wqpv-c3pp-3m58
6.6
OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
GHSA-wqpv-c3pp-3m58- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-829
- Updated
- 2026-11-02
NVD
6.6
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
CVE-2026-42510- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-829
- Updated
- 2026-11-02
OSV
6.6
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
CVE-2026-42510- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-829
- Updated
- 2026-11-07
OSVDEBIAN-CVE-2026-42510
7.2
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
DEBIAN-CVE-2026-42510- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-wqpv-c3pp-3m58
6.6
OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
GHSA-wqpv-c3pp-3m58- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-829
- Updated
- 2026-11-02
OSVPYSEC-2026-2525
6.6
OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
PYSEC-2026-2525- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-42510
6.6
OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.
- Record
UBUNTU-CVE-2026-42510- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ironicPyPI |
before 35.0.1 | 35.0.1 |
ironicDebian:12 |
before 1:21.1.0-3+deb12u1, plus listed versions 1:21.1.0-3 |
1:21.1.0-3+deb12u1 |
ironicDebian:13 |
before 1:29.0.5-0+deb13u1, plus listed versions 1:29.0.0-7 |
1:29.0.5-0+deb13u1 |
ironicDebian:14 |
before 1:35.0.1-1, plus listed versions 1:29.0.0-71:32.0.0-11:32.0.0-21:32.0.0-41:32.0.0-5 Show 5 moreShow less1:32.0.0-61:32.0.0-71:34.0.0-11:35.0.0-11:35.0.0-2 |
1:35.0.1-1 |
ironicPyPI |
before 35.0.1, plus listed versions 0.010.1.1010.1.710.1.810.1.9 Show 45 moreShow less11.1.111.1.211.1.311.1.412.0.012.1.012.1.112.1.212.1.312.1.412.1.512.1.612.2.013.0.013.0.113.0.213.0.313.0.413.0.513.0.613.0.714.0.015.0.015.0.115.0.215.1.015.2.016.0.016.0.116.0.216.0.316.0.416.0.516.1.016.2.017.0.017.0.117.0.217.0.317.0.417.1.018.0.018.1.018.2.018.2.1 |
35.0.1 |
ironicPyPI |
before 35.0.1, plus listed versions 0.010.1.1010.1.710.1.810.1.9 Show 45 moreShow less11.1.111.1.211.1.311.1.412.0.012.1.012.1.112.1.212.1.312.1.412.1.512.1.612.2.013.0.013.0.113.0.213.0.313.0.413.0.513.0.613.0.714.0.015.0.015.0.115.0.215.1.015.2.016.0.016.0.116.0.216.0.316.0.416.0.516.1.016.2.017.0.017.0.117.0.217.0.317.0.417.1.018.0.018.1.018.2.018.2.1 |
35.0.1 |
ironicUbuntu:16.04:LTS |
All versions, plus listed versions 1:4.2.0-0ubuntu11:4.3.0-0ubuntu11:5.1.0-0ubuntu11:5.1.2-0ubuntu1 |
None known |
openstackUbuntu:16.04:LTS |
All versions, plus listed versions 0.99.230.99.271.0.41.0.51.0.61.0.7.16.04.1 |
None known |
ironicUbuntu:18.04:LTS |
All versions, plus listed versions 1:9.1.0-0ubuntu21:9.2.0-0ubuntu11:10.0.0-0ubuntu11:10.1.0-0ubuntu11:10.1.1-0ubuntu11:10.1.1-0ubuntu2 |
None known |
ironicUbuntu:20.04:LTS |
All versions, plus listed versions 1:13.0.1-0ubuntu11:14.0.0~b1~git2019121713.76597ca93-0ubuntu11:14.0.0~b1~git2019121713.76597ca93-0ubuntu21:14.0.0-0ubuntu11:14.0.1~git2020032415.de2d907fc-0ubuntu11:14.0.1~git2020041013.af9e6ba90-0ubuntu21:15.0.0-0ubuntu0.20.04.1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
ironicUbuntu:22.04:LTS |
All versions, plus listed versions 1:18.2.0-0ubuntu11:18.2.0+git2021120910.cdc3b9538-0ubuntu11:19.0.0+git2022011216.7beadee46-0ubuntu11:20.0.0+git2022030313.4e6a3d52e-0ubuntu11:20.1.0-0ubuntu11:20.1.0-0ubuntu1.11:20.1.0-0ubuntu1.21:20.1.0-0ubuntu1.3 |
None known |
ironicUbuntu:24.04:LTS |
All versions, plus listed versions 1:23.0.0-0ubuntu31:23.1.0+git2024011916.a374a0c1-0ubuntu11:24.1.0-0ubuntu11:24.1.1-0ubuntu11:24.1.1-0ubuntu1.21:24.1.1-0ubuntu1.3 |
None known |
ironicUbuntu:25.10 |
All versions, plus listed versions 1:29.0.0-0ubuntu11:30.0.0+git2025070713.577833d78-0ubuntu11:30.0.0+git2025070713.577833d78-0ubuntu21:32.0.0-0ubuntu11:32.0.0-0ubuntu1.1 |
None known |
ironicUbuntu:26.10 |
All versions, plus listed versions 1:35.0.0-0ubuntu21:35.0.0-0ubuntu31:38.0.0+git20260818.101.f8e78b0-0ubuntu11:38.0.0+git2026091517.26c022f13-0ubuntu11:39.0.0-0ubuntu1 |
None known |
ironicUbuntu:26.04:LTS |
All versions, plus listed versions 1:32.0.0-0ubuntu11:34.0.0-0ubuntu11:35.0.0-0ubuntu11:35.0.0-0ubuntu21:35.0.0-0ubuntu2.1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-42510 is a medium vulnerability (CVSS 6.6) in Openstack Ironic, published April 28, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in ironic 35.0.1.
References
Left out here: 128 versions. The JSON record has them.