CVE-2026-44058
Authentication bypass via admin auth user
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.4
Authentication bypass via admin auth user
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
CVE-2026-44058- CVSS 3.1
- 6.4 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2026-31234
6.4
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
EUVD-2026-31234- CVSS 3.1
- 6.4 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-3jh8-xjh7-hwv3
7.2
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged...
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
GHSA-3jh8-xjh7-hwv3- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
NVD
7.2
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
CVE-2026-44058- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVALPINE-CVE-2026-44058
7.2
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
ALPINE-CVE-2026-44058- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2026-44058
7.2
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
DEBIAN-CVE-2026-44058- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-44058
7.2
An authentication bypass vulnerability in Netatalk 2.2.2 through 4.4.2 allows a remote privileged user to authenticate as an arbitrary user via the admin auth user mechanism.
- Record
UBUNTU-CVE-2026-44058- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
netatalkAlpine:v3.24 |
before 4.5.0-r0 | 4.5.0-r0 |
netatalkDebian:13 |
All versions, plus listed versions 4.2.3~ds-14.2.3~ds-1+deb13u14.2.3~ds-1+deb13u24.2.3~ds-24.2.3~ds-2.1 Show 7 moreShow less4.4.1~ds-14.4.2~ds-14.4.3~ds-14.5.0~ds-14.5.0~ds-24.5.0~ds-34.5.1~ds-1 |
None known |
netatalkDebian:14 |
before 4.5.0~ds-1, plus listed versions 4.2.3~ds-14.2.3~ds-24.2.3~ds-2.14.4.1~ds-14.4.2~ds-14.4.3~ds-1 |
4.5.0~ds-1 |
netatalkUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 2.2.2-1ubuntu12.2.2-1ubuntu22.2.2-1ubuntu2.22.2.2-1ubuntu2.2+esm12.2.2-1ubuntu2.2+esm22.2.2-1ubuntu2.2+esm32.2.2-1ubuntu2.2+esm4 |
None known |
netatalkUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.2.5-12.2.5-1ubuntu0.22.2.5-1ubuntu0.2+esm12.2.5-1ubuntu0.2+esm22.2.5-1ubuntu0.2+esm32.2.5-1ubuntu0.2+esm4 |
None known |
netatalkUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.2.6-12.2.6-1ubuntu0.18.04.22.2.6-1ubuntu0.18.04.2+esm12.2.6-1ubuntu0.18.04.2+esm22.2.6-1ubuntu0.18.04.2+esm32.2.6-1ubuntu0.18.04.2+esm4 |
None known |
netatalkUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 3.1.12~ds-33.1.12~ds-43.1.12~ds-4ubuntu0.20.04.13.1.12~ds-4ubuntu0.20.04.33.1.12~ds-4ubuntu0.20.04.3+esm13.1.12~ds-4ubuntu0.20.04.43.1.12~ds-4ubuntu0.20.04.4+esm13.1.12~ds-4ubuntu0.20.04.4+esm2 |
None known |
netatalkUbuntu:22.04:LTS |
All versions, plus listed versions 3.1.12~ds-93.1.12~ds-9build13.1.12~ds-9ubuntu0.22.04.13.1.12~ds-9ubuntu0.22.04.33.1.12~ds-9ubuntu0.22.04.4 |
None known |
netatalkUbuntu:24.04:LTS |
All versions, plus listed versions 3.1.15~ds-1ubuntu13.1.18~ds-13.1.18~ds-1build23.1.18~ds-1build4 |
None known |
netatalkUbuntu:25.10 |
All versions, plus listed versions 4.1.2~ds-44.2.1~ds-14.2.3~ds-1 |
None known |
netatalkUbuntu:26.04:LTS |
All versions, plus listed versions 4.2.3~ds-14.2.3~ds-24.2.3~ds-2.14.2.3~ds-2.1ubuntu0.14.2.3~ds-2.1ubuntu0.2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-44058 is a medium vulnerability (CVSS 6.4) in Netatalk, published May 21, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in netatalk 4.5.0-r0.