CVE-2026-44228
RT: Stored Cross-Site Scripting via insufficient template escaping
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
RT: Stored Cross-Site Scripting via insufficient template escaping
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
- Record
CVE-2026-44228- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2026-46049
5.4
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
- Record
EUVD-2026-46049- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
NVD
5.4
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
- Record
CVE-2026-44228- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
RT: Stored Cross-Site Scripting via insufficient template escaping
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
- Record
CVE-2026-44228- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-44228
5.4
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.
- Record
UBUNTU-CVE-2026-44228- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
request-tracker5Ubuntu:Pro:22.04:LTS |
All versions, plus listed versions 5.0.1+dfsg-1ubuntu15.0.1+dfsg-1ubuntu1+esm15.0.1+dfsg-1ubuntu1+esm2 |
None known |
request-tracker5Ubuntu:Pro:24.04:LTS |
All versions, plus listed versions 5.0.1+dfsg-1ubuntu15.0.5+dfsg-25.0.5+dfsg-2ubuntu0.1~esm15.0.5+dfsg-2ubuntu0.1~esm2 |
None known |
request-tracker5Ubuntu:26.10 |
All versions, plus listed versions 5.0.7+dfsg-65.0.10+dfsg-15.0.10+dfsg-3 |
None known |
request-tracker5Ubuntu:Pro:26.04:LTS |
All versions, plus listed versions 5.0.7+dfsg-45.0.7+dfsg-65.0.7+dfsg-6ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-44228 is a medium vulnerability (CVSS 5.4) in Bestpractical Rt, published July 20, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. No source names a fixed version.
References
github.com/bestpractical/rt/security/advisories/GHSA-pfgp-5j8g-phgc
github.com/bestpractical/rt/releases/tag/rt-6.0.3
github.com/CVEProject/cvelistV5/tree/main/cves/2026/44xxx/CVE-2026-44228.json
nvd.nist.gov/vuln/detail/CVE-2026-44228
ubuntu.com/security/CVE-2026-44228
cve.org/CVERecord?id=CVE-2026-44228