CVE-2026-46472
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file,...
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
CVE-2026-46472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
EUVDEUVD-2026-102937
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
EUVD-2026-102937- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2ffj-5jpx-7428
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file,...
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
GHSA-2ffj-5jpx-7428- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
NVD
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
CVE-2026-46472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVALPINE-CVE-2026-46472
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
ALPINE-CVE-2026-46472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-03
OSVDEBIAN-CVE-2026-46472
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
DEBIAN-CVE-2026-46472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-46472
7.5
An issue was discovered in GStreamer gst-plugins-good before 1.28.2. While parsing an MP4 file, the isomp4 plugin's qtdemux_parse_chnl function may read past the end of a global array, potentially leading to information disclosure.
- Record
UBUNTU-CVE-2026-46472- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-04
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gst-plugins-goodAlpine:v3.24 |
before 1.26.3-r0 | 1.26.3-r0 |
gst-plugins-good1.0Debian:13 |
before 1.26.2-1+deb13u1, plus listed versions 1.26.2-1 |
1.26.2-1+deb13u1 |
gst-plugins-good1.0Debian:14 |
before 1.28.2-1, plus listed versions 1.26.10-11.26.2-11.26.3-11.26.4-11.26.5-1 Show 14 moreShow less1.26.5-21.26.5-2+hurd.11.26.5-31.26.6-11.26.7-11.26.8-11.26.9-11.27.1-11.27.2-11.27.50-11.27.50-21.27.90-11.28.0-11.28.1-1 |
1.28.2-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | OSV | |
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-46472 is a high vulnerability (CVSS 7.5) in gst-plugins-good, published October 16, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.31%, the 23rd percentile. Fixed in gst-plugins-good 1.26.3-r0.
References
gstreamer.freedesktop.org/security/sa-2026-0018.html
nvd.nist.gov/vuln/detail/CVE-2026-46472
github.com/advisories/GHSA-2ffj-5jpx-7428
security.alpinelinux.org/vuln/CVE-2026-46472
security-tracker.debian.org/tracker/CVE-2026-46472
ubuntu.com/security/CVE-2026-46472
cve.org/CVERecord?id=CVE-2026-46472
gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/11243