CVE-2026-46588
Apache Camel: CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.3
Apache Camel: CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
CVE-2026-46588- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2026-41866
7.3
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
EUVD-2026-41866- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5g68-f6xg-vf2r
7.3
Apache Camel-CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
GHSA-5g68-f6xg-vf2r- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
7.3
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
CVE-2026-46588- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.3
Apache Camel: CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
CVE-2026-46588- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-5g68-f6xg-vf2r
7.3
Apache Camel-CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
Improper Input Validation vulnerability in Apache Camel.
This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0.
Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
- Record
GHSA-5g68-f6xg-vf2r- CVSS 3.1
- 7.3 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.camel:camel-couchdbMaven |
4.0.0 up to 4.14.8 | 4.14.8 |
org.apache.camel:camel-couchdbMaven |
4.15.0 up to 4.18.3 | 4.18.3 |
org.apache.camel:camel-couchdbMaven |
4.19.0 up to 4.21.0 | 4.21.0 |
org.apache.camel:camel-couchdbMaven |
4.0.0 up to 4.14.8, plus listed versions 4.0.14.0.24.0.34.0.44.0.5 Show 45 moreShow less4.0.64.1.04.10.04.10.14.10.24.10.34.10.44.10.54.10.64.10.74.10.84.10.94.11.04.12.04.13.04.14.04.14.14.14.24.14.34.14.44.14.54.14.64.14.74.2.04.3.04.4.04.4.14.4.24.4.34.4.44.4.54.5.04.6.04.7.04.8.04.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.8.94.9.0 |
4.14.8 |
org.apache.camel:camel-couchdbMaven |
4.15.0 up to 4.18.3, plus listed versions 4.16.04.17.04.18.04.18.14.18.2 |
4.18.3 |
org.apache.camel:camel-couchdbMaven |
4.19.0 up to 4.21.0, plus listed versions 4.20.0 |
4.21.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | oscerd/CVE-2026-46588 | 2026-07-15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-46588 is a high vulnerability (CVSS 7.3) in Apache Camel, published July 6, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 53rd percentile. Fixed in org.apache.camel:camel-couchdb 4.14.8.
References
camel.apache.org/security/CVE-2026-46588.html
openwall.com/lists/oss-security/2026/07/06/16
nvd.nist.gov/vuln/detail/CVE-2026-46588
github.com/apache/camel/pull/23228
github.com/apache/camel/pull/23230
github.com/apache/camel/pull/23231
Show 9 moreShow less
github.com/apache/camel/commit/22064a2acb85620020a3ea04706be2b4a33bfa7c
github.com/apache/camel/commit/354ab6203ea3438f091dead1337edef6b813a3fc
github.com/apache/camel/commit/f35286f9eaee6740482e6ef11f8c68d785c49567
github.com/apache/camel/releases/tag/camel-4.14.8
github.com/apache/camel/releases/tag/camel-4.18.3
github.com/apache/camel/releases/tag/camel-4.21.0
github.com/advisories/GHSA-5g68-f6xg-vf2r
github.com/CVEProject/cvelistV5/tree/main/cves/2026/46xxx/CVE-2026-46588.json
github.com/apache/camel