CVE-2026-46718
Apache Calcite: A user-controled model can load arbitrary classes, leading to code execution
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Apache Calcite: A user-controled model can load arbitrary classes, leading to code execution
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
CVE-2026-46718- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-470
- Updated
- 2026-11-02
EUVDEUVD-2026-33906
6.5
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
EUVD-2026-33906- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c2rv-hwqm-wjpg
6.5
Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
GHSA-c2rv-hwqm-wjpg- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-470
- Updated
- 2026-11-02
NVD
6.5
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
CVE-2026-46718- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-470
- Updated
- 2026-11-02
OSV
6.5
Apache Calcite: A user-controled model can load arbitrary classes, leading to code execution
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
CVE-2026-46718- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-470
- Updated
- 2026-11-02
OSVGHSA-c2rv-hwqm-wjpg
6.5
Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.
This issue affects Apache Calcite: from 1.5.0 before 1.42.
Users are recommended to upgrade to version 1.42, which fixes the issue.
- Record
GHSA-c2rv-hwqm-wjpg- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-470
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.calcite:calcite-coreMaven |
1.5.0 up to 1.42.0 | 1.42.0 |
org.apache.calcite:calcite-coreMaven |
1.5.0 up to 1.42.0, plus listed versions 1.10.01.11.01.12.01.13.01.14.0 Show 31 moreShow less1.15.01.16.01.17.01.18.01.19.01.20.01.21.01.22.01.23.01.24.01.25.01.26.01.27.01.28.01.29.01.30.01.31.01.32.01.33.01.34.01.35.01.36.01.37.01.38.01.39.01.40.01.41.01.6.01.7.01.8.01.9.0 |
1.42.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-46718 is a medium vulnerability (CVSS 6.5) in Apache Calcite, published June 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in org.apache.calcite:calcite-core 1.42.0.
References
lists.apache.org/thread/9s37svo343w5ck1ovh478lkzcqk4949v
openwall.com/lists/oss-security/2026/06/01/7
nvd.nist.gov/vuln/detail/CVE-2026-46718
github.com/apache/calcite/commit/5855cfa14d8038e2a123ff6ce9722edce0e0cc25
issues.apache.org/jira/browse/CALCITE-7532
github.com/advisories/GHSA-c2rv-hwqm-wjpg
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2026/46xxx/CVE-2026-46718.json
github.com/apache/calcite