Every CVE Search/ Get API key

CVE-2026-49042

Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

7.3 HighPublic exploitFix available

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.69%Up 0.5 points since Jul 7, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.3

Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-49042
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2026-41864 7.3

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
EUVD-2026-41864
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-hh8r-75r6-qrg9 7.3

Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
GHSA-hh8r-75r6-qrg9
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
NVD 7.3

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-49042
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSV 7.3

Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
CVE-2026-49042
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-hh8r-75r6-qrg9 7.3

Apache Camel-Langchain4j-Tools: Tool argument headers are not filtered against declared parameters

Improper Input Validation vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0.

Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Record
GHSA-hh8r-75r6-qrg9
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-langchain4j-tools
Maven
4.8.0 up to 4.18.3
4.18.3
org.apache.camel:camel-langchain4j-tools
Maven
4.19.0 up to 4.21.0
4.21.0
org.apache.camel:camel-langchain4j-agent
Maven
4.8.0 up to 4.18.3
4.18.3
org.apache.camel:camel-langchain4j-agent
Maven
4.19.0 up to 4.21.0
4.21.0
org.apache.camel:camel-spring-ai-tools
Maven
4.8.0 up to 4.18.3
4.18.3
org.apache.camel:camel-spring-ai-tools
Maven
4.19.0 up to 4.21.0
4.21.0
org.apache.camel:camel-langchain4j-tools
Maven
4.8.0 up to 4.18.3, plus listed versions
4.10.04.10.14.10.24.10.34.10.4
Show 34 moreShow less
4.10.54.10.64.10.74.10.84.10.94.11.04.12.04.13.04.14.04.14.14.14.24.14.34.14.44.14.54.14.64.14.74.14.84.14.94.15.04.16.04.17.04.18.04.18.14.18.24.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.8.94.9.0
4.18.3
org.apache.camel:camel-langchain4j-tools
Maven
4.19.0 up to 4.21.0, plus listed versions
4.20.0
4.21.0
org.apache.camel:camel-langchain4j-agent
Maven
4.8.0 up to 4.18.3, plus listed versions
4.14.04.14.14.14.24.14.34.14.4
Show 11 moreShow less
4.14.54.14.64.14.74.14.84.14.94.15.04.16.04.17.04.18.04.18.14.18.2
4.18.3
org.apache.camel:camel-langchain4j-agent
Maven
4.19.0 up to 4.21.0, plus listed versions
4.20.0
4.21.0
org.apache.camel:camel-spring-ai-tools
Maven
4.8.0 up to 4.18.3, plus listed versions
4.17.04.18.04.18.14.18.2
4.18.3
org.apache.camel:camel-spring-ai-tools
Maven
4.19.0 up to 4.21.0, plus listed versions
4.20.0
4.21.0

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHuboscerd/CVE-2026-490422026-07-20

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-49042 is a high vulnerability (CVSS 7.3) in Apache Camel, published July 6, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.69%, the 52nd percentile. Fixed in org.apache.camel:camel-langchain4j-tools 4.18.3.

References

Show 8 moreShow less
MoveEnter Open