Every CVE Search/ Get API key

CVE-2026-49158

Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

7.5 HighFix available

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.03%Down 0.1 points since Jul 28, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.5

Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-49158
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-409
Updated
2026-11-02
EUVDEUVD-2026-49151 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
EUVD-2026-49151
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-jcj7-w43p-gjh8 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift...

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
GHSA-jcj7-w43p-gjh8
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-409
Updated
2026-11-02
NVD 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-49158
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-409
Updated
2026-11-02
OSV 7.5

Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-49158
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-409
Updated
2026-11-02
OSVDEBIAN-CVE-2026-49158 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
DEBIAN-CVE-2026-49158
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVRHSA-2026:49837 8.4

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Record
RHSA-2026:49837
CVSS 3.1
8.4 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-49158 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
UBUNTU-CVE-2026-49158
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBIT-thrift-2026-49158 No score

Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
BIT-thrift-2026-49158
Updated
2026-11-02
OSVopenSUSE-SU-2026:11432-1 No score

libthrift-0_24_0-0.24.0-1.1 on GA media

These are all security issues fixed in the libthrift-0_24_0-0.24.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11432-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
thrift
Bitnami
before 0.24.0
0.24.0
thrift
Debian:12
All versions, plus listed versions
0.17.0-20.17.0-30.17.0-40.18.1-10.18.1-2
Show 17 moreShow less
0.19.0-10.19.0-20.19.0-2.10.19.0-2.1~exp10.19.0-30.19.0-40.20.0-10.22.0-10.22.0-20.22.0-30.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-20.24.0-3
None known
thrift
Debian:13
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 7 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-20.24.0-3
None known
thrift
Debian:14
before 0.24.0-2, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 5 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-1
0.24.0-2
perl-thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
python3-thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift-devel
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift-glib
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift-qt
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
ruby-thrift
Ubuntu:20.04:LTS
All versions, plus listed versions
0.11.0.0-20.11.0.0-2build1
None known
ruby-thrift
Ubuntu:22.04:LTS
All versions, plus listed versions
0.11.0.0-30.14.0-20.14.0-2build10.14.0-3
None known
ruby-thrift
Ubuntu:24.04:LTS
All versions, plus listed versions
0.16.0-20.16.0-2build10.16.0-2build2
None known
thrift
openSUSE:Tumbleweed
From an advisory covering 14 CVEs
before 0.24.0-1.1
0.24.0-1.1

History

History
RecordedChangedSources
affected, facts
affected, aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-49158 is a high vulnerability (CVSS 7.5) in Apache Thrift, published July 27, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. Fixed in thrift 0.24.0.

References

Show 68 moreShow less
MoveEnter Open