CVE-2026-51105
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a...
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
CVE-2026-51105- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
EUVDEUVD-2026-43685
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
EUVD-2026-43685- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-7r93-5v7x-h4c9
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a...
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
GHSA-7r93-5v7x-h4c9- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
NVD
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
CVE-2026-51105- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-121
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-51105
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
DEBIAN-CVE-2026-51105- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-51105
7.5
Buffer Overflow vulnerability in aMULE-Project aMule v.2.3.3 allows a remote attacker to cause a denial of service via the OP_SERVERMESSAGE Handler.
- Record
UBUNTU-CVE-2026-51105- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
amuleDebian:12 |
All versions, plus listed versions 1:2.3.3-31:2.3.3-3.11:2.3.3-3.21:2.3.3-41:2.3.3-4.1 Show 4 moreShow less1:3.0.1-11:3.1.0-11:3.1.0-21:3.1.0-3 |
None known |
amuleDebian:13 |
All versions, plus listed versions 1:2.3.3-3.21:2.3.3-41:2.3.3-4.11:3.0.1-11:3.1.0-11:3.1.0-21:3.1.0-3 |
None known |
amuleDebian:14 |
before 1:3.0.1-1, plus listed versions 1:2.3.3-3.21:2.3.3-41:2.3.3-4.1 |
1:3.0.1-1 |
amuleUbuntu:16.04:LTS |
All versions, plus listed versions 2.3.1+git1a369e47-3build12.4.0~git20151120.0023527bc2-12.4.0~git20151120.0023527bc2-1ubuntu1 |
None known |
amuleUbuntu:18.04:LTS |
All versions, plus listed versions 1:2.3.2-1build21:2.3.2-1build31:2.3.2-2 |
None known |
amuleUbuntu:22.04:LTS |
All versions, plus listed versions 1:2.3.3-11:2.3.3-2 |
None known |
amuleUbuntu:24.04:LTS |
All versions, plus listed versions 1:2.3.3-3build11:2.3.3-3build41:2.3.3-3build5 |
None known |
amuleUbuntu:26.10 |
All versions, plus listed versions 1:2.3.3-3.21:2.3.3-41:2.3.3-4.11:3.0.1-1 |
None known |
amuleUbuntu:26.04:LTS |
All versions, plus listed versions 1:2.3.3-3.2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-51105 is a high vulnerability (CVSS 7.5) in amule, published July 14, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in amule 1:3.0.1-1.