Every CVE Search/ Get API key

CVE-2026-55970

Apache Thrift: C++ heap out-of-bounds read in THeaderTransport::readHeaderFormat()

6.9 MediumFix available

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
Low

Exploit likelihood

0.78%Down 0.1 points since Jul 28, 2026
90%50%10%1%

What each source reports

CVE List Score used 6.9

Apache Thrift: C++ heap out-of-bounds read in THeaderTransport::readHeaderFormat()

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-55970
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-126
Updated
2026-11-02
EUVDEUVD-2026-49154 6.9

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
EUVD-2026-49154
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-g7xp-pggm-c7w2 6.9

Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift:...

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
GHSA-g7xp-pggm-c7w2
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Weakness
CWE-126
Updated
2026-11-02
NVD 6.9

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-55970
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Weakness
CWE-126
Updated
2026-11-02
OSV 6.9

Apache Thrift: C++ heap out-of-bounds read in THeaderTransport::readHeaderFormat()

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
CVE-2026-55970
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-126
Updated
2026-11-02
OSVDEBIAN-CVE-2026-55970 6.5

Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
DEBIAN-CVE-2026-55970
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Updated
2026-11-02
Show 5 moreShow less
OSVRHSA-2026:49837 8.4

Red Hat Security Advisory: Red Hat Hardened Images RPMs bug fix and enhancement update

Record
RHSA-2026:49837
CVSS 3.1
8.4 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-55970 6.9

Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
UBUNTU-CVE-2026-55970
CVSS 4.0
6.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Updated
2026-11-02
OSVAZL-93986 No score

CVE-2026-55970 affecting package thrift for versions less than 0.24.0-1

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
AZL-93986
Updated
2026-11-02
OSVBIT-thrift-2026-55970 No score

Apache Thrift: C++ heap out-of-bounds read in THeaderTransport::readHeaderFormat()

Buffer Over-read vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Record
BIT-thrift-2026-55970
Updated
2026-11-02
OSVopenSUSE-SU-2026:11432-1 No score

libthrift-0_24_0-0.24.0-1.1 on GA media

These are all security issues fixed in the libthrift-0_24_0-0.24.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11432-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
thrift
Azure Linux:3
before 0.24.0-1
0.24.0-1
thrift
Bitnami
before 0.24.0
0.24.0
thrift
Debian:12
All versions, plus listed versions
0.17.0-20.17.0-30.17.0-40.18.1-10.18.1-2
Show 17 moreShow less
0.19.0-10.19.0-20.19.0-2.10.19.0-2.1~exp10.19.0-30.19.0-40.20.0-10.22.0-10.22.0-20.22.0-30.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-20.24.0-3
None known
thrift
Debian:13
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 7 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-20.24.0-3
None known
thrift
Debian:14
before 0.24.0-2, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 5 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-1
0.24.0-2
perl-thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
python3-thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift-devel
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift-glib
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
thrift-qt
Red Hat:hummingbird:1
From an advisory covering 9 CVEs
before 0:0.24.0-0.1.hum1
0:0.24.0-0.1.hum1
thrift
Ubuntu:20.04:LTS
All versions, plus listed versions
0.11.0-60.13.0-2build10.13.0-2build2
None known
thrift
Ubuntu:22.04:LTS
All versions, plus listed versions
0.13.0-6ubuntu10.13.0-6ubuntu20.13.0-6ubuntu30.13.0-70.16.0-2
None known
thrift
Ubuntu:24.04:LTS
All versions, plus listed versions
0.17.0-40.19.0-20.19.0-2build10.19.0-2.1build40.19.0-2.1build5
None known
thrift
Ubuntu:26.10
All versions, plus listed versions
0.22.0-3ubuntu10.23.0-30.23.0-3ubuntu1
None known
thrift
Ubuntu:26.04:LTS
All versions, plus listed versions
0.19.0-4build10.22.0-30.22.0-3ubuntu1
None known
thrift
openSUSE:Tumbleweed
From an advisory covering 14 CVEs
before 0.24.0-1.1
0.24.0-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-55970 is a medium vulnerability (CVSS 6.9) in Apache Thrift, published July 27, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in thrift 0.24.0-1.

References

Show 70 moreShow less
MoveEnter Open