Every CVE Search/ Get API key

CVE-2026-56702

Adminer before 5.4.3 Unrestricted File Upload via AdminerFileUpload

7.1 HighFix available

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.62%Up 0.3 points since Aug 25, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.1

Adminer before 5.4.3 Unrestricted File Upload via AdminerFileUpload

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
CVE-2026-56702
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-434
Updated
2026-11-02
EUVDEUVD-2026-65200 7.1

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
EUVD-2026-65200
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-p84v-vg3f-p9m6 7.1

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the...

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
GHSA-p84v-vg3f-p9m6
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-434
Updated
2026-11-02
NVD 7.1

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
CVE-2026-56702
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-434
Updated
2026-11-02
OSV 7.1

Adminer before 5.4.3 Unrestricted File Upload via AdminerFileUpload

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
CVE-2026-56702
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness
CWE-434
Updated
2026-11-02
OSVDEBIAN-CVE-2026-56702 7.1

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
DEBIAN-CVE-2026-56702
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-56702 7.1

Adminer versions before 5.4.3 contain an unrestricted file upload vulnerability in the AdminerFileUpload plugin that allows authenticated users to upload PHP files by exploiting a permissive default extension allowlist. Attackers can upload PHP webshells to columns ending in _path and execute arbitrary code as the web-server user when uploadPath is web-served.

Record
UBUNTU-CVE-2026-56702
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
adminer
Debian:12
All versions, plus listed versions
4.8.1-14.8.1-24.8.1-45.1.0-15.2.1+dfsg-1
Show 12 moreShow less
5.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-15.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-1
None known
adminer
Debian:13
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
Show 8 moreShow less
5.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-1
None known
adminer
Debian:14
before 5.4.3+dfsg-1, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-1
5.4.3+dfsg-1
adminer
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1ubuntu14.2.1-1ubuntu1+esm1
None known
adminer
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
4.3.1-24.5.0-14.6.1-14.6.2-14.6.2-1ubuntu0.1~esm1
None known
adminer
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
4.7.2-14.7.4-14.7.5-14.7.6-14.7.6-1ubuntu0.1~esm1
None known
adminer
Ubuntu:22.04:LTS
All versions, plus listed versions
4.7.9-24.8.1-1
None known
adminer
Ubuntu:24.04:LTS
All versions, plus listed versions
4.8.1-14.8.1-1ubuntu14.8.1-2
None known
adminer
Ubuntu:26.04:LTS
All versions, plus listed versions
5.2.1+dfsg-15.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-56702 is a high vulnerability (CVSS 7.1) in Vrana Adminer, published August 25, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in adminer 5.4.3+dfsg-1.

References

MoveEnter Open