CVE-2026-61372
Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
CVE-2026-61372- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2026-52338
7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
EUVD-2026-52338- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-g2qm-wc55-9539
7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in...
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
GHSA-g2qm-wc55-9539- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
NVD
7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
CVE-2026-61372- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
7.5
Apache Jena Fuseki: Web requests using SPARQL Update can escape file restrictions
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki.
This issue affects Apache Jena Fuseki: through 6.1.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
CVE-2026-61372- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-61372
7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
DEBIAN-CVE-2026-61372- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-61372
7.5
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Jena Fuseki. This issue affects Apache Jena Fuseki: through 6.1.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.
- Record
UBUNTU-CVE-2026-61372- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apache-jenaDebian:12 |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaDebian:13 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaDebian:14 |
All versions, plus listed versions 4.9.0-1 |
None known |
apache-jenaUbuntu:22.04:LTS |
All versions, plus listed versions 3.17.0-13.17.0-23.17.0-3 |
None known |
apache-jenaUbuntu:24.04:LTS |
All versions, plus listed versions 4.5.0-24.9.0-1 |
None known |
apache-jenaUbuntu:26.10 |
All versions, plus listed versions 4.9.0-1build1 |
None known |
apache-jenaUbuntu:26.04:LTS |
All versions, plus listed versions 4.9.0-14.9.0-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-61372 is a high vulnerability (CVSS 7.5) in Apache Jena Fuseki, published August 3, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. No source names a fixed version.
References
lists.apache.org/thread/h206tpxtbzts7m254og6ffqljjdjkm84
openwall.com/lists/oss-security/2026/08/03/5
nvd.nist.gov/vuln/detail/CVE-2026-61372
github.com/advisories/GHSA-g2qm-wc55-9539
github.com/CVEProject/cvelistV5/tree/main/cves/2026/61xxx/CVE-2026-61372.json
security-tracker.debian.org/tracker/CVE-2026-61372
ubuntu.com/security/CVE-2026-61372
cve.org/CVERecord?id=CVE-2026-61372