CVE-2026-63316
SQL Injection in Payload CMS
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.7
SQL Injection in Payload CMS
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
- Record
CVE-2026-63316- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2026-98471
8.7
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
- Record
EUVD-2026-98471- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-57gg-gh75-cfjg
8.7
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of...
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
- Record
GHSA-57gg-gh75-cfjg- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
8.7
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
- Record
CVE-2026-63316- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVCVE-2026-105856
8.6
Payload: SQL injection in SQLite/Postgres
Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.
- Record
CVE-2026-105856- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
8.7
SQL Injection in Payload CMS
A SQL injection vulnerability has been identified in Payload CMS. Improper neutralization of input provided by user into "in" and "not_in" query paramethers allows an authenticated attacker to perform SQL Injection attacks.
This issue was fixed in version 3.90.0 and 4.0.0-canary.34.
- Record
CVE-2026-63316- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-pj7x-6wpf-pgvp
8.6
Payload: SQL injection in SQLite/Postgres
Impact
An attacker who has read plus create or update access to a collection can submit a request that includes a SQL injection targeting a specific field path shape and operators in Payload's SQLite and Postgres.
You are affected if:
- You use
@payloadcms/db-sqliteor@payloadcms/db-d1-sqlite. - You use
@payloadcms/db-postgresor@payloadcms/db-vercel-postgres< 3.73.0. - A readable collection has a
jsonfield, or ablocksfield withblocksAsJSON: true. - The attacker has read plus create or update access on it.
You are not affected if:
- You have no
json orblocksAsJSONfields.richText` is not affected. - You run a patched version.
Patches
The patched version sanitizes the query input to prevent injection.
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
- Record
GHSA-pj7x-6wpf-pgvp- CVSS 4.0
- 8.6 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@payloadcms/db-sqlitenpm From an advisory covering 2 CVEs |
3.0.0 up to 3.90.0 | 3.90.0 |
@payloadcms/db-d1-sqlitenpm From an advisory covering 2 CVEs |
3.0.0 up to 3.90.0 | 3.90.0 |
@payloadcms/db-postgresnpm From an advisory covering 2 CVEs |
3.0.0 up to 3.73.0 | 3.73.0 |
@payloadcms/db-vercel-postgresnpm From an advisory covering 2 CVEs |
3.0.0 up to 3.73.0 | 3.73.0 |
@payloadcms/db-sqlitenpm From an advisory covering 2 CVEs |
4.0.0-canary.0 up to 4.0.0-canary.34 | 4.0.0-canary.34 |
@payloadcms/db-d1-sqlitenpm From an advisory covering 2 CVEs |
4.0.0-canary.0 up to 4.0.0-canary.34 | 4.0.0-canary.34 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-63316 is a high vulnerability (CVSS 8.7) in Payload Cms, published October 6, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. No source names a fixed version.
References
cert.pl/posts/2026/10/CVE-2026-63316
github.com/payloadcms/payload/security/advisories/GHSA-pj7x-6wpf-pgvp
nvd.nist.gov/vuln/detail/CVE-2026-63316
cert.pl/posts/2026/11/CVE-2026-63316
github.com/advisories/GHSA-57gg-gh75-cfjg
github.com/payloadcms/payload/releases/tag/v3.90.0
Show 5 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2026/105xxx/CVE-2026-105856.json
nvd.nist.gov/vuln/detail/CVE-2026-105856
github.com/payloadcms/payload/commit/03b78c7e0901d19c67f07bdf6396a276010adbcc
github.com/CVEProject/cvelistV5/tree/main/cves/2026/63xxx/CVE-2026-63316.json
github.com/payloadcms/payload