CVE-2026-66142
Apache Neethi: Uncontrolled recursion in policy processing
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache Neethi: Uncontrolled recursion in policy processing
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
- Record
CVE-2026-66142- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2026-48578
7.5
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
- Record
EUVD-2026-48578- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vfqj-r56j-g77w
7.5
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids...
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
- Record
GHSA-vfqj-r56j-g77w- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.5
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
- Record
CVE-2026-66142- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
7.5
Apache Neethi: Uncontrolled recursion in policy processing
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
- Record
CVE-2026-66142- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVRHLW-2026-2f27e699c38d33d5
7.5
Lightwell Security Advisory: neethi 3.2.2.rhlw-00006
Red Hat Lightwell has released org.apache.neethi:neethi 3.2.2.rhlw-00006 with backported fixes for CVE-2026-66142, CVE-2026-66143, and CVE-2026-66144.
CVE-2026-66142: Apache Neethi: Uncontrolled recursion in policy processing
CVE-2026-66143: Apache Neethi: Missing global alternative-output budget across policy computation paths
CVE-2026-66144: Apache Neethi: Remote PolicyReference fetch lacks resource bounds
This patched artifact is a drop-in replacement for org.apache.neethi:neethi 3.2.2 from Maven Central.
- Record
RHLW-2026-2f27e699c38d33d5- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.neethi:neethiRed Hat Lightwell:Maven From an advisory covering 3 CVEs |
before 3.2.2.rhlw-00006, plus listed versions 2.02.0.12.0.22.0.32.0.4 Show 10 moreShow less2.0.53.0.03.0.13.0.23.0.33.1.03.1.13.2.03.2.13.2.2 |
3.2.2.rhlw-00006 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-66142 is a high vulnerability (CVSS 7.5) in Apache Neethi, published July 24, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. No source names a fixed version.
References
lists.apache.org/thread/fomwtwt4pzzhxn4fyn3skykto913vfzt
openwall.com/lists/oss-security/2026/07/24/8
nvd.nist.gov/vuln/detail/CVE-2026-66142
github.com/advisories/GHSA-vfqj-r56j-g77w
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2026/66xxx/CVE-2026-66142.json
Show 6 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2026/66xxx/CVE-2026-66143.json
lists.apache.org/thread/s6o6p5pvcbcsk54dlg6j699t5gxol28w
nvd.nist.gov/vuln/detail/CVE-2026-66143
github.com/CVEProject/cvelistV5/tree/main/cves/2026/66xxx/CVE-2026-66144.json
lists.apache.org/thread/80xwwbhkqvbwkkmco6yl6fr5xkpdysjf
nvd.nist.gov/vuln/detail/CVE-2026-66144