Every CVE Search/ Get API key

CVE-2026-6664

PgBouncer integer overflow in PgBouncer network packet parsing

7.5 HighPublic exploitFix available

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.70%Up 0.7 points since May 9, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.5

PgBouncer integer overflow in PgBouncer network packet parsing

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
CVE-2026-6664
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2026-28876 7.5

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
EUVD-2026-28876
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-pmgp-q838-fh9g 7.5

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary...

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
GHSA-pmgp-q838-fh9g
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 7.5

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
CVE-2026-6664
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSVDEBIAN-CVE-2026-6664 7.5

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
DEBIAN-CVE-2026-6664
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2026-6664 7.5

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
UBUNTU-CVE-2026-6664
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVAZL-86234 No score

CVE-2026-6664 affecting package pgbouncer for versions less than 1.25.2-1

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
AZL-86234
Updated
2026-11-02
OSVBIT-pgbouncer-2026-6664 No score

PgBouncer integer overflow in PgBouncer network packet parsing

An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

Record
BIT-pgbouncer-2026-6664
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgbouncer
Azure Linux:3
before 1.25.2-1
1.25.2-1
pgbouncer
Bitnami
before 1.25.2
1.25.2
pgbouncer
Debian:12
All versions, plus listed versions
1.18.0-11.18.0-1+deb12u11.19.0-11.19.1-11.20.0-1
Show 17 moreShow less
1.20.1-11.21.0-11.22.0-11.22.1-11.23.0-11.23.1-11.24.0-21.24.0-31.24.1-11.25.0-11.25.0-21.25.1-11.25.2-11.26.0-11.26.0-21.26.0-31.26.0-4
None known
pgbouncer
Debian:13
before 1.24.1-1+deb13u2, plus listed versions
1.24.1-11.24.1-1+deb13u1
1.24.1-1+deb13u2
pgbouncer
Debian:14
before 1.25.2-1, plus listed versions
1.24.1-11.25.0-11.25.0-21.25.1-1
1.25.2-1
pgbouncer
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5.5-11.6.1-11.7-1
None known
pgbouncer
Ubuntu:18.04:LTS
All versions, plus listed versions
1.7.2-3build11.7.2-65-g2b8e6cf-11.8.1-11.8.1-1build1
None known
pgbouncer
Ubuntu:20.04:LTS
All versions, plus listed versions
1.10.0-11.10.0-1build11.11.0-11.12.0-21.12.0-3
None known
pgbouncer
Ubuntu:22.04:LTS
All versions, plus listed versions
1.15.0-11.16.1-1ubuntu1
None known
pgbouncer
Ubuntu:24.04:LTS
All versions, plus listed versions
1.20.0-11.21.0-11.22.0-11.22.0-1build11.22.0-1build31.22.0-1build4
None known
pgbouncer
Ubuntu:25.10
All versions, plus listed versions
1.24.0-31.24.1-1
None known
pgbouncer
Ubuntu:26.10
All versions, plus listed versions
1.25.1-11.25.2-11.25.2-1ubuntu1
None known
pgbouncer
Ubuntu:26.04:LTS
All versions, plus listed versions
1.24.1-11.25.0-21.25.1-1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubnicolasjulian/bouncer-overflow2026-05-12

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-6664 is a high vulnerability (CVSS 7.5) in Pgbouncer, published May 9, 2026. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.70%, the 53rd percentile. Fixed in pgbouncer 1.25.2-1.

References

MoveEnter Open