CVE-2026-67590
Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
CVE-2026-67590- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
EUVDEUVD-2026-53085
7.5
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
EUVD-2026-53085- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hgf5-hpf4-qmrr
7.5
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError...
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
GHSA-hgf5-hpf4-qmrr- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
NVD
7.5
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
CVE-2026-67590- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
OSV
7.5
Apache Qpid ProtonJ2: Unbounded type nesting can lead to pre-authentication stackoverflow
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.
This issue affects Apache Qpid ProtonJ2: through 1.1.0.
Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
CVE-2026-67590- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-67590
7.5
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
UBUNTU-CVE-2026-67590- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-67590 No score
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
- Record
DEBIAN-CVE-2026-67590- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
qpid-protonUbuntu:16.04:LTS |
All versions, plus listed versions 0.7-20.10-2 |
None known |
qpid-protonUbuntu:18.04:LTS |
All versions, plus listed versions 0.14.0-5.10.14.0-5.1ubuntu1 |
None known |
qpid-protonUbuntu:20.04:LTS |
All versions, plus listed versions 0.22.0-3.20.22.0-3.2build10.22.0-3.30.22.0-3.3build1 |
None known |
qpid-protonUbuntu:22.04:LTS |
All versions, plus listed versions 0.22.0-5.10.22.0-5.1build10.22.0-5.1ubuntu10.22.0-5.1ubuntu2 |
None known |
qpid-protonUbuntu:24.04:LTS |
All versions, plus listed versions 0.37.0-2build10.37.0-2build20.37.0-2build40.37.0-2build5 |
None known |
qpid-protonUbuntu:26.10 |
All versions, plus listed versions 0.37.0-7build10.37.0-80.37.0-90.37.0-9build1 |
None known |
qpid-protonUbuntu:26.04:LTS |
All versions, plus listed versions 0.37.0-60.37.0-6build10.37.0-70.37.0-7build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-67590 is a high vulnerability (CVSS 7.5) in Apache Qpid Protonj2, published August 5, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.77%, the 55th percentile. No source names a fixed version.
References
lists.apache.org/thread/kmov6k7f3moqy01m1s370fl61vgos3ly
openwall.com/lists/oss-security/2026/08/04/29
nvd.nist.gov/vuln/detail/CVE-2026-67590
github.com/advisories/GHSA-hgf5-hpf4-qmrr
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2026/67xxx/CVE-2026-67590.json
security-tracker.debian.org/tracker/CVE-2026-67590
ubuntu.com/security/CVE-2026-67590
cve.org/CVERecord?id=CVE-2026-67590