CVE-2026-68005
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service...
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
CVE-2026-68005- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2026-60449
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
EUVD-2026-60449- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wwgh-7wm5-gx34
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service...
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
GHSA-wwgh-7wm5-gx34- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
CVE-2026-68005- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-68005
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
DEBIAN-CVE-2026-68005- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-68005
7.5
An issue in ACME mini_httpd 1.30 and prior allows a remote attacker to cause a denial of service via the HTTP request header parser in the handle_request() function
- Record
UBUNTU-CVE-2026-68005- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mini-httpdDebian:12 |
All versions, plus listed versions 1.30-101.30-111.30-121.30-131.30-14 Show 11 moreShow less1.30-151.30-161.30-171.30-181.30-31.30-41.30-51.30-61.30-71.30-81.30-9 |
None known |
mini-httpdDebian:13 |
All versions, plus listed versions 1.30-131.30-141.30-151.30-161.30-171.30-18 |
None known |
mini-httpdDebian:14 |
before 1.30-18, plus listed versions 1.30-131.30-141.30-151.30-161.30-17 |
1.30-18 |
mini-httpdUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.19-9.31.19-9.3ubuntu0.1~esm1 |
None known |
mini-httpdUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.19-9.31.21-1ubuntu11.23-11.23-1ubuntu0.1~esm1 |
None known |
mini-httpdUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.23-1.21.23-1.2build11.23-1.2ubuntu0.1~esm1 |
None known |
mini-httpdUbuntu:20.04:LTS |
All versions, plus listed versions 1.30-2 |
None known |
mini-httpdUbuntu:22.04:LTS |
All versions, plus listed versions 1.30-21.30-2build1 |
None known |
mini-httpdUbuntu:24.04:LTS |
All versions, plus listed versions 1.30-31.30-51.30-61.30-71.30-81.30-8build11.30-8build2 |
None known |
mini-httpdUbuntu:26.10 |
All versions, plus listed versions 1.30-151.30-171.30-17build11.30-18 |
None known |
mini-httpdUbuntu:26.04:LTS |
All versions, plus listed versions 1.30-131.30-141.30-15 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-68005 is a high vulnerability (CVSS 7.5) in mini-httpd, published August 17, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 47th percentile. Fixed in mini-httpd 1.30-18.
References
acme.com/software/mini_httpd
github.com/qop-qop-qop/qop-s-blog.github.io/blob/main/CVE-2026-68005/CVE-2026-68005.md
nvd.nist.gov/vuln/detail/CVE-2026-68005
github.com/advisories/GHSA-wwgh-7wm5-gx34
security-tracker.debian.org/tracker/CVE-2026-68005
ubuntu.com/security/CVE-2026-68005
cve.org/CVERecord?id=CVE-2026-68005