Every CVE Search/ Get API key

CVE-2026-70652

libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map

2.0 LowFix available

CVE-2026-70652 is a low vulnerability (CVSS 2.0) in Libvips, published August 20, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.14%, the 3rd percentile. Fixed in vips 8.18.3-1.

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
Low

Exploit likelihood

0.14%Unchanged since Aug 21, 2026
90%50%10%1%

What each source reports

CVE List Score used 2.0

libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
CVE-2026-70652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-126
Updated
2026-11-02
EUVDEUVD-2026-63652 2.0

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
EUVD-2026-63652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-02
NVD 2.0

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
CVE-2026-70652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-126
Updated
2026-11-02
OSV 2.0

libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
CVE-2026-70652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness
CWE-126
Updated
2026-11-02
OSVDEBIAN-CVE-2026-70652 2.0

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
DEBIAN-CVE-2026-70652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-70652 2.0

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.

Record
UBUNTU-CVE-2026-70652
CVSS 4.0
2.0 LowCVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N
Updated
2026-11-03
OSVopenSUSE-SU-2026:12266-1 No score

libvips-devel-8.18.7-1.1 on GA media

These are all security issues fixed in the libvips-devel-8.18.7-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12266-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vips
Debian:14
before 8.18.3-1, plus listed versions
8.16.1-18.16.1-28.17.3-18.17.3-28.18.0-1
Show 4 moreShow less
8.18.0-28.18.0-38.18.1-18.18.2-1
8.18.3-1
vips
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
7.40.6-2ubuntu28.0.2-28.2.1-18.2.2-18.2.2-1ubuntu0.1~esm1
None known
vips
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
8.4.5-1build18.4.5-1ubuntu0.1~esm18.4.5-1ubuntu0.1~esm2
None known
vips
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
8.7.4-1build18.8.3-38.8.3-3ubuntu18.9.0-18.9.0-1build1
Show 4 moreShow less
8.9.1-18.9.1-28.9.1-2ubuntu0.1~esm18.9.1-2ubuntu0.1~esm2
None known
vips
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
8.10.5-2ubuntu18.11.4-28.12.1-18.12.1-1build18.12.1-1ubuntu0.1~esm18.12.1-1ubuntu0.1~esm28.12.1-1ubuntu0.1~esm3
None known
vips
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
8.14.3-18.14.5-18.15.0-18.15.0-28.15.1-1
Show 5 moreShow less
8.15.1-1build18.15.1-1.1build38.15.1-1.1build48.15.1-1.1ubuntu0.1~esm18.15.1-1.1ubuntu0.1~esm2
None known
vips
Ubuntu:Pro:26.04:LTS
All versions, plus listed versions
8.16.1-18.16.1-28.17.3-28.18.0-18.18.0-1build18.18.0-1ubuntu0.1~esm18.18.0-1ubuntu0.1~esm2
None known
vips
openSUSE:Tumbleweed
before 8.18.7-1.1
8.18.7-1.1

History

History
WhenChangedSources
2026-11-03affected, factsOSV
2026-11-02aliases, publishedEUVD
2026-11-02createdCVE List, NVD, OSV

References

Show 12 moreShow less
MoveEnter Open