CVE-2026-75421
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
CVE-2026-75421- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
EUVDEUVD-2026-66178
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
EUVD-2026-66178- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8w4g-6qwv-67hv
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
GHSA-8w4g-6qwv-67hv- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
NVD
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
CVE-2026-75421- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-121
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-75421
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
DEBIAN-CVE-2026-75421- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-75421
4.0
aria2 <=1.37.0 has a stack-buffer-underflow vulnerability in the IOFile::getLine() function.
- Record
UBUNTU-CVE-2026-75421- CVSS 3.1
- 4.0 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11843-1 No score
aria2-1.37.0-3.1 on GA media
These are all security issues fixed in the aria2-1.37.0-3.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11843-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2026:21997-1 No score
Security update for aria2
This update for aria2 fixes the following issues:
Changes in aria2:
-
CVE-2026-75421: stack buffer underflow in IOFile::getLine() when a line begins with a NUL byte (boo#1276754)
-
Fix build with Nettle 4.0 [be1caa2d] (bsc#1257934)
- Record
openSUSE-SU-2026:21997-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
aria2Debian:12 |
All versions, plus listed versions 1.36.0-11.36.0-2 |
None known |
aria2Debian:13 |
All versions, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 45 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.10.0-11.10.0-21.10.6-11.10.9-11.11.1-11.11.2-11.12.0-11.12.1-11.12.1-21.13.0-11.14.0-11.14.1-11.14.2-11.14.2-21.15.0-11.15.0-21.15.1-11.15.2-11.16.0-11.16.1-11.17.0-11.18.0-11.18.0-21.18.1-11.18.10-11.18.10-21.18.3-11.18.5-11.18.7-11.18.8-11.19.0-11.2.0-11.21.0-1 |
None known |
aria2Debian:14 |
All versions, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 45 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.10.0-11.10.0-21.10.6-11.10.9-11.11.1-11.11.2-11.12.0-11.12.1-11.12.1-21.13.0-11.14.0-11.14.1-11.14.2-11.14.2-21.15.0-11.15.0-21.15.1-11.15.2-11.16.0-11.16.1-11.17.0-11.18.0-11.18.0-21.18.1-11.18.10-11.18.10-21.18.3-11.18.5-11.18.7-11.18.8-11.19.0-11.2.0-11.21.0-1 |
None known |
aria2Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.17.0-11.18.0-11.18.0-1ubuntu21.18.0-21.18.1-11.18.1-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.19.0-11.19.0-1build11.19.0-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.32.0-11.32.0-21.33.1-11.33.1-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:20.04:LTS |
All versions, plus listed versions 1.34.0-41.35.0-11.35.0-1build1 |
None known |
aria2Ubuntu:22.04:LTS |
All versions, plus listed versions 1.35.0-31.36.0-1 |
None known |
aria2Ubuntu:24.04:LTS |
All versions, plus listed versions 1.36.0-21.37.0+debian-11.37.0+debian-1build11.37.0+debian-1build21.37.0+debian-1build3 |
None known |
aria2Ubuntu:26.10 |
All versions, plus listed versions 1.37.0+debian-4 |
None known |
aria2Ubuntu:26.04:LTS |
All versions, plus listed versions 1.37.0+debian-3build11.37.0+debian-4 |
None known |
aria2openSUSE:Tumbleweed |
before 1.37.0-3.1 | 1.37.0-3.1 |
aria2openSUSE:Leap 16.0 |
before 1.37.0-bp160.2.1 | 1.37.0-bp160.2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-75421 is a medium vulnerability (CVSS 4.0) in aria2, published August 25, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.16%, the 4th percentile. Fixed in aria2 1.37.0-3.1.
References
Left out here: 70 versions. The JSON record has them.