CVE-2026-75880
Apache Artemis, Apache ActiveMQ Artemis: Message selector wildcard handling could lead to denial of service
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.5
Apache Artemis, Apache ActiveMQ Artemis: Message selector wildcard handling could lead to denial of service
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
- Record
CVE-2026-75880- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
EUVDEUVD-2026-75244
6.5
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
- Record
EUVD-2026-75244- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-c9m2-388v-p4rq
6.5
An authenticated client could attach a consumer with a selector containing crafted wildcard usage...
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
- Record
GHSA-c9m2-388v-p4rq- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
NVD
6.5
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
- Record
CVE-2026-75880- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSV
6.5
Apache Artemis, Apache ActiveMQ Artemis: Message selector wildcard handling could lead to denial of service
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
- Record
CVE-2026-75880- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-1333
- Updated
- 2026-11-02
OSVCLSA-2026-1793195078 No score
TuxCare security update for org.apache.activemq (5 CVEs)
TuxCare rebuilt 5 org.apache.activemq packages to address 5 CVEs. Fixed in 2.37.0-tuxcare.3.
- Record
CLSA-2026-1793195078- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.activemq:artemis-core-clientTuxCare:Maven From an advisory covering 5 CVEs |
2.37.0 up to 2.37.0-tuxcare.3, plus listed versions 2.37.0-tuxcare.12.37.0-tuxcare.2 |
2.37.0-tuxcare.3 |
org.apache.activemq:artemis-jakarta-openwire-protocolTuxCare:Maven From an advisory covering 5 CVEs |
2.37.0 up to 2.37.0-tuxcare.3, plus listed versions 2.37.0-tuxcare.12.37.0-tuxcare.2 |
2.37.0-tuxcare.3 |
org.apache.activemq:artemis-openwire-protocolTuxCare:Maven From an advisory covering 5 CVEs |
2.37.0 up to 2.37.0-tuxcare.3, plus listed versions 2.37.0-tuxcare.12.37.0-tuxcare.2 |
2.37.0-tuxcare.3 |
org.apache.activemq:artemis-selectorTuxCare:Maven From an advisory covering 5 CVEs |
2.37.0 up to 2.37.0-tuxcare.3, plus listed versions 2.37.0-tuxcare.12.37.0-tuxcare.2 |
2.37.0-tuxcare.3 |
org.apache.activemq:artemis-serverTuxCare:Maven From an advisory covering 5 CVEs |
2.37.0 up to 2.37.0-tuxcare.3, plus listed versions 2.37.0-tuxcare.12.37.0-tuxcare.2 |
2.37.0-tuxcare.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-75880 is a medium vulnerability (CVSS 6.5) in Apache Artemis, published September 10, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. No source names a fixed version.