CVE-2026-82858
@hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.3
@hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
- Record
CVE-2026-82858- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-345
- Updated
- 2026-11-02
EUVDEUVD-2026-68446
9.3
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
- Record
EUVD-2026-68446- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2ffm-hxrq-qqmm
8.7
@hulumi/drift: Orphan reconciler accepted externally supplied execute plans
Impact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted.
Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage.
Remediation: upgrade @hulumi/drift to 1.3.2 or later.
- Record
GHSA-2ffm-hxrq-qqmm- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-345
- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wpxp-22v5-r9cx
9.3
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient...
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
- Record
GHSA-wpxp-22v5-r9cx- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-345
- Updated
- 2026-11-02
NVD
9.3
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
- Record
CVE-2026-82858- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-345
- Updated
- 2026-11-02
OSV
9.3
@hulumi/drift before 1.3.2 Unsafe Execute Plan Acceptance
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
- Record
CVE-2026-82858- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-345
- Updated
- 2026-11-02
OSVGHSA-2ffm-hxrq-qqmm
8.7
@hulumi/drift: Orphan reconciler accepted externally supplied execute plans
Impact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted.
Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage.
Remediation: upgrade @hulumi/drift to 1.3.2 or later.
- Record
GHSA-2ffm-hxrq-qqmm- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-345
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@hulumi/driftnpm |
before 1.3.2 | 1.3.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-82858 is a critical vulnerability (CVSS 9.3) in Hulumi Drift, published May 21, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in @hulumi/drift 1.3.2.
References
github.com/kerberosmansour/hulumi/security/advisories/GHSA-2ffm-hxrq-qqmm
vulncheck.com/advisories/hulumi-drift-before-1.3.2-unsafe-execute-plan-acceptance
github.com/advisories/GHSA-2ffm-hxrq-qqmm
nvd.nist.gov/vuln/detail/CVE-2026-82858
github.com/advisories/GHSA-wpxp-22v5-r9cx
github.com/CVEProject/cvelistV5/tree/main/cves/2026/82xxx/CVE-2026-82858.json
github.com/kerberosmansour/hulumi