CVE-2026-8367
aria2c Improper Certificate Validation
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.8
aria2c Improper Certificate Validation
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
CVE-2026-8367- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
EUVDEUVD-2026-30042
4.8
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
EUVD-2026-30042- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-rpx3-3f8j-f6v2
4.8
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers...
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
GHSA-rpx3-3f8j-f6v2- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
NVD
4.8
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
CVE-2026-8367- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSV
4.8
aria2c Improper Certificate Validation
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
CVE-2026-8367- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-8367
5.3
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
DEBIAN-CVE-2026-8367- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVJLSEC-2026-1347
5.3
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers...
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
JLSEC-2026-1347- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-8367
4.8
aria2c accepts a server certificate with incorrect Extended Key Usage (EKU). If the attackers compromise a certificate (with the associated private key) issued for a different purpose, they may be able to reuse it for TLS server authentication.
- Record
UBUNTU-CVE-2026-8367- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
aria2Debian:12 |
All versions, plus listed versions 1.36.0-11.36.0-2 |
None known |
aria2Debian:13 |
All versions, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 45 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.10.0-11.10.0-21.10.6-11.10.9-11.11.1-11.11.2-11.12.0-11.12.1-11.12.1-21.13.0-11.14.0-11.14.1-11.14.2-11.14.2-21.15.0-11.15.0-21.15.1-11.15.2-11.16.0-11.16.1-11.17.0-11.18.0-11.18.0-21.18.1-11.18.10-11.18.10-21.18.3-11.18.5-11.18.7-11.18.8-11.19.0-11.2.0-11.21.0-1 |
None known |
aria2Debian:14 |
All versions, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 45 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.10.0-11.10.0-21.10.6-11.10.9-11.11.1-11.11.2-11.12.0-11.12.1-11.12.1-21.13.0-11.14.0-11.14.1-11.14.2-11.14.2-21.15.0-11.15.0-21.15.1-11.15.2-11.16.0-11.16.1-11.17.0-11.18.0-11.18.0-21.18.1-11.18.10-11.18.10-21.18.3-11.18.5-11.18.7-11.18.8-11.19.0-11.2.0-11.21.0-1 |
None known |
Aria2_jllJulia |
before 1.37.0+0 | 1.37.0+0 |
aria2Ubuntu:Pro:14.04:LTS |
All versions, plus listed versions 1.17.0-11.18.0-11.18.0-1ubuntu21.18.0-21.18.1-11.18.1-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.19.0-11.19.0-1build11.19.0-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.32.0-11.32.0-21.33.1-11.33.1-1ubuntu0.1~esm1 |
None known |
aria2Ubuntu:20.04:LTS |
All versions, plus listed versions 1.34.0-41.35.0-11.35.0-1build1 |
None known |
aria2Ubuntu:22.04:LTS |
All versions, plus listed versions 1.35.0-31.36.0-1 |
None known |
aria2Ubuntu:24.04:LTS |
All versions, plus listed versions 1.36.0-21.37.0+debian-11.37.0+debian-1build11.37.0+debian-1build21.37.0+debian-1build3 |
None known |
aria2Ubuntu:25.10 |
All versions, plus listed versions 1.37.0+debian-31.37.0+debian-3build1 |
None known |
aria2Ubuntu:26.10 |
All versions, plus listed versions 1.37.0+debian-4 |
None known |
aria2Ubuntu:26.04:LTS |
All versions, plus listed versions 1.37.0+debian-3build11.37.0+debian-4 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-8367 is a medium vulnerability (CVSS 4.8) in Aria2 Project Aria2, published May 13, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.13%, the 2nd percentile. Fixed in Aria2_jll 1.37.0+0.
References
tenable.com/security/research/tra-2026-38
nvd.nist.gov/vuln/detail/CVE-2026-8367
github.com/advisories/GHSA-rpx3-3f8j-f6v2
github.com/CVEProject/cvelistV5/tree/main/cves/2026/8xxx/CVE-2026-8367.json
security-tracker.debian.org/tracker/CVE-2026-8367
ubuntu.com/security/CVE-2026-8367
cve.org/CVERecord?id=CVE-2026-8367
github.com/aria2/aria2/issues/2355
Left out here: 70 versions. The JSON record has them.