CVE-2026-84971
Persistent client crash loop via undersized FLE2 insert-update ciphertext in decryption path
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.1
Persistent client crash loop via undersized FLE2 insert-update ciphertext in decryption path
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
CVE-2026-84971- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
EUVDEUVD-2026-70507
7.1
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
EUVD-2026-70507- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-pxxc-vwf4-r3mr
7.1
Improper handling of an unexpected value size in the decryption path of a client-side encryption...
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
GHSA-pxxc-vwf4-r3mr- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
NVD
7.1
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
CVE-2026-84971- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
OSV
7.1
Persistent client crash loop via undersized FLE2 insert-update ciphertext in decryption path
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
CVE-2026-84971- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-617
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-84971
7.1
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
DEBIAN-CVE-2026-84971- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-84971
7.1
Improper handling of an unexpected value size in the decryption path of a client-side encryption library can cause a failed internal check that terminates the process using the library. A party able to place a suitably formed encrypted value where an application will decrypt it, or able to control the responses the application receives, may cause that application to stop running.
- Record
UBUNTU-CVE-2026-84971- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libmongocryptDebian:12 |
All versions, plus listed versions 1.10.0-11.10.1-11.11.0-11.12.0-11.13.0-1 Show 18 moreShow less1.13.1-11.13.2-11.16.0-11.17.0-11.17.3-11.18.1-11.18.2-11.19.0-11.19.1-11.20.0-11.20.1-11.20.2-11.20.3-11.20.4-11.7.2-11.8.2-11.8.4-11.9.1-1 |
None known |
libmongocryptDebian:13 |
All versions, plus listed versions 1.13.2-11.13.2-1+deb13u11.16.0-11.17.0-11.17.3-1 Show 9 moreShow less1.18.1-11.18.2-11.19.0-11.19.1-11.20.0-11.20.1-11.20.2-11.20.3-11.20.4-1 |
None known |
libmongocryptDebian:14 |
before 1.20.4-1, plus listed versions 1.13.2-11.16.0-11.17.0-11.17.3-11.18.1-1 Show 7 moreShow less1.18.2-11.19.0-11.19.1-11.20.0-11.20.1-11.20.2-11.20.3-1 |
1.20.4-1 |
libmongocryptUbuntu:22.04:LTS |
All versions, plus listed versions 1.2.1-11.2.2-11.3.0-11.3.0-1ubuntu1 |
None known |
libmongocryptUbuntu:24.04:LTS |
All versions, plus listed versions 1.7.2-11.8.2-11.8.4-11.8.4-1build21.8.4-1build3 |
None known |
libmongocryptUbuntu:26.10 |
All versions, plus listed versions 1.17.0-11.19.0-11.19.1-11.20.0-11.20.1-1build11.20.2-1 |
None known |
libmongocryptUbuntu:26.04:LTS |
All versions, plus listed versions 1.13.2-11.17.0-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-84971 is a high vulnerability (CVSS 7.1) in Mongodb Libmongocrypt, published September 3, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.26%, the 17th percentile. Fixed in libmongocrypt 1.20.4-1.
References
jira.mongodb.org/browse/MONGOCRYPT-971
nvd.nist.gov/vuln/detail/CVE-2026-84971
github.com/advisories/GHSA-pxxc-vwf4-r3mr
github.com/CVEProject/cvelistV5/tree/main/cves/2026/84xxx/CVE-2026-84971.json
security-tracker.debian.org/tracker/CVE-2026-84971
ubuntu.com/security/CVE-2026-84971
cve.org/CVERecord?id=CVE-2026-84971