Every CVE Search/ Get API key

CVE-2026-86589

Apache Answer: User Center integration does not revoke first-login sessions after central account suspension

5.4 Medium

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.25%Unchanged since Oct 20, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.4

Apache Answer: User Center integration does not revoke first-login sessions after central account suspension

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Record
CVE-2026-86589
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-303
Updated
2026-11-02
EUVDEUVD-2026-104164 5.4

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Record
EUVD-2026-104164
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-9w3m-gv8w-f7ww 5.4

Incorrect implementation of authentication algorithm vulnerability in Apache Answer. This...

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Record
GHSA-9w3m-gv8w-f7ww
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-303
Updated
2026-11-02
NVD 5.4

Incorrect implementation of authentication algorithm vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.2.

A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked.

Users are recommended to upgrade to version 2.0.3, which fixes the issue.

Record
CVE-2026-86589
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weakness
CWE-303
Updated
2026-11-02

Affected products

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-86589 is a medium vulnerability (CVSS 5.4) in Apache Software Foundation Answer, published October 19, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. No source names a fixed version.

References

MoveEnter Open