Every CVE Search/ Get API key

CVE-2026-88964

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows...

7.1 HighFix available

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
High

Exploit likelihood

0.38%Down 0.1 points since Oct 14, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.1

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Record
CVE-2026-88964
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-191, CWE-125
Updated
2026-11-02
EUVDEUVD-2026-100755 7.1

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Record
EUVD-2026-100755
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-wm7f-2ghj-7r8c 7.1

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows...

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Record
GHSA-wm7f-2ghj-7r8c
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-125
Updated
2026-11-02
NVD 7.1

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Record
CVE-2026-88964
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-125, CWE-191
Updated
2026-11-02
OSVDEBIAN-CVE-2026-88964 7.1

An integer underflow in OpenVPN version 2.7_alpha3 through 2.7.7 on Windows and Android allows remote authenticated servers to cause a denial of service or memory disclosure via crafted domain search options

Record
DEBIAN-CVE-2026-88964
CVSS 4.0
7.1 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-88964 No score

[Unknown description]

Record
UBUNTU-CVE-2026-88964
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openvpn
Debian:12
All versions, plus listed versions
2.6.11-12.6.12-12.6.13-12.6.14-0+deb12u12.6.14-0+deb12u2
Show 40 moreShow less
2.6.14-12.6.14-22.6.15-12.6.3-12.6.3-1+deb12u12.6.3-1+deb12u1~bpo11+12.6.3-1+deb12u22.6.3-1+deb12u2~bpo11+12.6.3-1+deb12u32.6.3-1+deb12u42.6.3-22.6.3-2.12.6.7-12.6.9-12.7.0-12.7.0-1~bpo13+12.7.0~alpha1-12.7.0~alpha2-12.7.0~alpha3-12.7.0~beta1-12.7.0~beta2-12.7.0~beta3-12.7.0~rc1-12.7.0~rc2-12.7.0~rc2-22.7.0~rc3-12.7.0~rc4-12.7.0~rc5-12.7.0~rc6-12.7.1-12.7.1-1~bpo13+12.7.2-12.7.2-1~bpo13+12.7.3-12.7.5-12.7.5-1~bpo13+12.7.7-12.7.7-1~bpo13+12.7.8-12.7.8-1~bpo13+1
None known
openvpn
Debian:13
All versions, plus listed versions
2.6.14-12.6.14-1+deb13u12.6.14-1+deb13u22.6.14-1+deb13u32.6.14-2
Show 27 moreShow less
2.6.15-12.7.0-12.7.0-1~bpo13+12.7.0~alpha1-12.7.0~alpha2-12.7.0~alpha3-12.7.0~beta1-12.7.0~beta2-12.7.0~beta3-12.7.0~rc1-12.7.0~rc2-12.7.0~rc2-22.7.0~rc3-12.7.0~rc4-12.7.0~rc5-12.7.0~rc6-12.7.1-12.7.1-1~bpo13+12.7.2-12.7.2-1~bpo13+12.7.3-12.7.5-12.7.5-1~bpo13+12.7.7-12.7.7-1~bpo13+12.7.8-12.7.8-1~bpo13+1
None known
openvpn
Debian:14
before 2.7.8-1, plus listed versions
2.6.14-12.6.14-22.6.15-12.7.0-12.7.0-1~bpo13+1
Show 23 moreShow less
2.7.0~alpha1-12.7.0~alpha2-12.7.0~alpha3-12.7.0~beta1-12.7.0~beta2-12.7.0~beta3-12.7.0~rc1-12.7.0~rc2-12.7.0~rc2-22.7.0~rc3-12.7.0~rc4-12.7.0~rc5-12.7.0~rc6-12.7.1-12.7.1-1~bpo13+12.7.2-12.7.2-1~bpo13+12.7.3-12.7.5-12.7.5-1~bpo13+12.7.7-12.7.7-1~bpo13+12.7.8-1~bpo13+1
2.7.8-1

History

History
RecordedChangedSources
affected
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-88964 is a high vulnerability (CVSS 7.1) in Openvpn, published October 8, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 31st percentile. Fixed in openvpn 2.7.8-1.

References

MoveEnter Open