Every CVE Search/ Get API key

CVE-2026-90558

sngrep through 1.8.4 Stack Buffer Overflow via SIP Headers

9.3 CriticalFix available

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.88%Up 0.4 points since Sep 14, 2026
90%50%10%1%

What each source reports

CVE List Score used 9.3

sngrep through 1.8.4 Stack Buffer Overflow via SIP Headers

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
CVE-2026-90558
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2026-76903 9.3

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
EUVD-2026-76903
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-5vq7-hmwf-89w5 9.3

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting...

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
GHSA-5vq7-hmwf-89w5
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-121
Updated
2026-11-02
NVD 9.3

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
CVE-2026-90558
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-121
Updated
2026-11-02
OSV 9.3

sngrep through 1.8.4 Stack Buffer Overflow via SIP Headers

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
CVE-2026-90558
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-121
Updated
2026-11-02
OSVDEBIAN-CVE-2026-90558 9.3

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
DEBIAN-CVE-2026-90558
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-90558 9.3

sngrep through 1.8.4 contains stack buffer overflow vulnerabilities in SIP attribute formatting routines when header values exceed the 255-byte buffer limit. Attackers can craft malicious SIP packets with oversized Call-ID, X-Call-ID, or other header fields to overflow stack buffers and cause crashes or execute arbitrary code during packet parsing and rendering.

Record
UBUNTU-CVE-2026-90558
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2026:11791-1 No score

sngrep-1.8.4-2.1 on GA media

These are all security issues fixed in the sngrep-1.8.4-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11791-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sngrep
Debian:12
All versions, plus listed versions
1.6.0-11.7.0-11.7.0-21.7.0-2~bpo12+11.8.0-1
Show 8 moreShow less
1.8.1-11.8.2-11.8.2-1~bpo12+11.8.3-11.8.3-1~bpo13+11.8.4-11.8.4-1~bpo13+11.8.4-2
None known
sngrep
Debian:13
All versions, plus listed versions
1.8.2-11.8.3-11.8.3-1~bpo13+11.8.4-11.8.4-1~bpo13+11.8.4-2
None known
sngrep
Debian:14
before 1.8.4-2, plus listed versions
1.8.2-11.8.3-11.8.3-1~bpo13+11.8.4-11.8.4-1~bpo13+1
1.8.4-2
sngrep
Ubuntu:16.04:LTS
All versions, plus listed versions
0.4.1-11.0.0-11.1.0-11.2.0-11.2.0-1build1
None known
sngrep
Ubuntu:18.04:LTS
All versions, plus listed versions
1.4.3-11.4.4-11.4.4-21.4.5-1
None known
sngrep
Ubuntu:20.04:LTS
All versions, plus listed versions
1.4.6-11.4.6-2
None known
sngrep
Ubuntu:22.04:LTS
All versions, plus listed versions
1.4.9-11.4.10-11.4.10-1ubuntu0.1
None known
sngrep
Ubuntu:24.04:LTS
All versions, plus listed versions
1.7.0-21.8.0-11.8.0-1build11.8.0-1build2
None known
sngrep
Ubuntu:26.10
All versions, plus listed versions
1.8.3-11.8.4-1
None known
sngrep
Ubuntu:26.04:LTS
All versions, plus listed versions
1.8.2-11.8.3-1
None known
sngrep
openSUSE:Tumbleweed
before 1.8.4-2.1
1.8.4-2.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-90558 is a critical vulnerability (CVSS 9.3) in Irontec Sngrep, published September 12, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in sngrep 1.8.4-2.

References

Show 6 moreShow less
MoveEnter Open