CVE-2026-91018
Double Free in lwIP (lightweight IP)
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.7
Double Free in lwIP (lightweight IP)
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
CVE-2026-91018- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
EUVDEUVD-2026-84864
8.7
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
EUVD-2026-84864- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-rmx4-24pf-8x6h
8.7
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS,...
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
GHSA-rmx4-24pf-8x6h- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
NVD
8.7
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
CVE-2026-91018- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-91018
8.7
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
DEBIAN-CVE-2026-91018- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-91018
8.7
lwIP (Lightweight IP) has a double free vulnerability, which could crash the system, cause a DoS, memory corruption, or allow code execution on the victim system.
- Record
UBUNTU-CVE-2026-91018- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lwipDebian:12 |
All versions, plus listed versions 2.1.3+dfsg1-22.1.3+dfsg1-32.1.3+dfsg1-42.2.0+dfsg1-12.2.0+dfsg1-2 Show 17 moreShow less2.2.0+dfsg1-32.2.0+dfsg1-42.2.0+dfsg1-52.2.0+dfsg1-62.2.0+dfsg1-6.12.2.0+dfsg1-6.1~exp12.2.0+dfsg1-72.2.0+dfsg1-82.2.0+dfsg1-92.2.1+dfsg1-12.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-42.2.1+dfsg1-52.2.1+dfsg1-62.2.1+dfsg1-72.2.1+dfsg1-8 |
None known |
lwipDebian:13 |
All versions, plus listed versions 2.2.1+dfsg1-12.2.1+dfsg1-1+deb13u12.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-4 Show 4 moreShow less2.2.1+dfsg1-52.2.1+dfsg1-62.2.1+dfsg1-72.2.1+dfsg1-8 |
None known |
lwipDebian:14 |
before 2.2.1+dfsg1-8, plus listed versions 2.2.1+dfsg1-12.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-42.2.1+dfsg1-52.2.1+dfsg1-62.2.1+dfsg1-7 |
2.2.1+dfsg1-8 |
lwipUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 2.1.2-32.1.2-5.12.1.2+dfsg1-12.1.2+dfsg1-42.1.2+dfsg1-4ubuntu0.1~esm1 |
None known |
lwipUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 2.1.2+dfsg1-82.1.2+dfsg1-92.1.3+dfsg1-12.1.3+dfsg1-1ubuntu0.1~esm1 |
None known |
lwipUbuntu:Pro:24.04:LTS |
All versions, plus listed versions 2.1.3+dfsg1-22.1.3+dfsg1-42.2.0+dfsg1-22.2.0+dfsg1-32.2.0+dfsg1-4 Show 6 moreShow less2.2.0+dfsg1-52.2.0+dfsg1-62.2.0+dfsg1-6.12.2.0+dfsg1-6.1build12.2.0+dfsg1-6.1build22.2.0+dfsg1-6.1ubuntu0.1~esm1 |
None known |
lwipUbuntu:26.10 |
All versions, plus listed versions 2.2.1+dfsg1-42.2.1+dfsg1-52.2.1+dfsg1-7 |
None known |
lwipUbuntu:Pro:26.04:LTS |
All versions, plus listed versions 2.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-42.2.1+dfsg1-4ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-91018 is a high vulnerability (CVSS 8.7) in Lwip Api, published September 22, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in lwip 2.2.1+dfsg1-8.
References
cgit.git.savannah.gnu.org/cgit/lwip.git
cisa.gov/news-events/ics-advisories/icsa-26-265-02
github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-265-02.json
nvd.nist.gov/vuln/detail/CVE-2026-91018
github.com/advisories/GHSA-rmx4-24pf-8x6h
security-tracker.debian.org/tracker/CVE-2026-91018
ubuntu.com/security/CVE-2026-91018
cve.org/CVERecord?id=CVE-2026-91018