Every CVE Search/ Get API key

CVE-2026-91137

Apache Thrift: PHP `thrift_protocol` accelerator: zero-byte container elements

8.7 HighFix available

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.28%Down 0.1 points since Oct 3, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.7

Apache Thrift: PHP `thrift_protocol` accelerator: zero-byte container elements

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
CVE-2026-91137
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-1284, CWE-770, CWE-834
Updated
2026-11-02
EUVDEUVD-2026-91372 8.7

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
EUVD-2026-91372
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-r276-xrw4-gpgm 8.7

Improper validation of specified quantity in input, Allocation of resources without limits or...

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
GHSA-r276-xrw4-gpgm
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-770
Updated
2026-11-02
NVD 8.7

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
CVE-2026-91137
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-770, CWE-834, CWE-1284
Updated
2026-11-02
OSVDEBIAN-CVE-2026-91137 8.7

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
DEBIAN-CVE-2026-91137
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-91137 8.7

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
UBUNTU-CVE-2026-91137
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
OSVAZL-106620 No score

CVE-2026-91137 affecting package thrift 0.24.0-1

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
AZL-106620
Updated
2026-11-02
OSVBIT-thrift-2026-91137 No score

Apache Thrift: PHP `thrift_protocol` accelerator: zero-byte container elements

Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
BIT-thrift-2026-91137
Updated
2026-11-02
OSVopenSUSE-SU-2026:12051-1 No score

libthrift-0_25_0-0.25.0-1.1 on GA media

These are all security issues fixed in the libthrift-0_25_0-0.25.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12051-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
thrift
Azure Linux:3
through 0.24.0-1 None known
thrift
Bitnami
before 0.25.0
0.25.0
thrift
Debian:12
All versions, plus listed versions
0.17.0-20.17.0-30.17.0-40.18.1-10.18.1-2
Show 16 moreShow less
0.19.0-10.19.0-20.19.0-2.10.19.0-2.1~exp10.19.0-30.19.0-40.20.0-10.22.0-10.22.0-20.22.0-30.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
thrift
Debian:13
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 6 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
thrift
Debian:14
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 6 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
thrift
Ubuntu:20.04:LTS
All versions, plus listed versions
0.11.0-60.13.0-2build10.13.0-2build2
None known
thrift
Ubuntu:22.04:LTS
All versions, plus listed versions
0.13.0-6ubuntu10.13.0-6ubuntu20.13.0-6ubuntu30.13.0-70.16.0-2
None known
thrift
Ubuntu:24.04:LTS
All versions, plus listed versions
0.17.0-40.19.0-20.19.0-2build10.19.0-2.1build40.19.0-2.1build5
None known
thrift
Ubuntu:26.10
All versions, plus listed versions
0.22.0-3ubuntu10.23.0-30.23.0-3ubuntu1
None known
thrift
Ubuntu:26.04:LTS
All versions, plus listed versions
0.19.0-4build10.22.0-30.22.0-3ubuntu1
None known
thrift
openSUSE:Tumbleweed
From an advisory covering 33 CVEs
before 0.25.0-1.1
0.25.0-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-91137 is a high vulnerability (CVSS 8.7) in Apache Software Foundation Thrift, published October 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in thrift 0.25.0.

References

Show 34 moreShow less
MoveEnter Open