CVE-2026-92868
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an...
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.9
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
- Record
CVE-2026-92868- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
EUVDEUVD-2026-89658
6.9
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
- Record
EUVD-2026-89658- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-gw2w-g7v3-wgff
6.9
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an...
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
- Record
GHSA-gw2w-g7v3-wgff- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
NVD
6.9
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
- Record
CVE-2026-92868- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-92868
6.9
An improper certificate validation vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to bypass client certificate authentication.
- Record
DEBIAN-CVE-2026-92868- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pgpool2Debian:12 |
All versions, plus listed versions 4.3.5-14.3.5-1+deb12u14.3.5-24.3.5-34.3.7-1 Show 23 moreShow less4.3.7-1.1~exp14.3.7-24.5.2-14.5.4-14.5.4-24.5.4-34.5.5-14.6.0-14.6.0-24.6.1-14.6.1-24.6.2-14.6.3-14.6.3-24.6.3-34.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-24.7.3-1 |
None known |
pgpool2Debian:13 |
All versions, plus listed versions 4.6.1-24.6.2-14.6.3-14.6.3-24.6.3-3 Show 8 moreShow less4.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-24.7.3-1 |
None known |
pgpool2Debian:14 |
before 4.7.3-1, plus listed versions 4.6.1-24.6.2-14.6.3-14.6.3-24.6.3-3 Show 7 moreShow less4.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-2 |
4.7.3-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-92868 is a medium vulnerability (CVSS 6.9) in Pgpool Global Development Group Pgpool-ii, published September 30, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.15%, the 4th percentile. Fixed in pgpool2 4.7.3-1.