Every CVE Search/ Get API key

CVE-2026-92870

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an...

8.7 HighFix available

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.32%Unchanged since Sep 30, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.7

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Record
CVE-2026-92870
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2026-89660 8.7

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Record
EUVD-2026-89660
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-8gw9-wqrc-j3gj 8.7

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an...

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Record
GHSA-8gw9-wqrc-j3gj
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
NVD 8.7

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Record
CVE-2026-92870
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-121
Updated
2026-11-02
OSVDEBIAN-CVE-2026-92870 8.7

A stack-based buffer overflow vulnerability exists in Pgpool-II, which may allow an unauthenticated attacker to cause abnormal process termination.

Record
DEBIAN-CVE-2026-92870
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgpool2
Debian:12
All versions, plus listed versions
4.3.5-14.3.5-1+deb12u14.3.5-24.3.5-34.3.7-1
Show 23 moreShow less
4.3.7-1.1~exp14.3.7-24.5.2-14.5.4-14.5.4-24.5.4-34.5.5-14.6.0-14.6.0-24.6.1-14.6.1-24.6.2-14.6.3-14.6.3-24.6.3-34.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-24.7.3-1
None known
pgpool2
Debian:13
All versions, plus listed versions
4.6.1-24.6.2-14.6.3-14.6.3-24.6.3-3
Show 8 moreShow less
4.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-24.7.3-1
None known
pgpool2
Debian:14
before 4.7.3-1, plus listed versions
4.6.1-24.6.2-14.6.3-14.6.3-24.6.3-3
Show 7 moreShow less
4.6.3-44.6.4-14.6.5-14.7.0-14.7.1-14.7.2-14.7.2-2
4.7.3-1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-92870 is a high vulnerability (CVSS 8.7) in Pgpool Global Development Group Pgpool-ii, published September 30, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 25th percentile. Fixed in pgpool2 4.7.3-1.

References

MoveEnter Open