Every CVE Search/ Get API key

CVE-2026-94055

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after...

3.7 LowFix available

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.29%Unchanged since Sep 20, 2026
90%50%10%1%

What each source reports

CVE List Score used 3.7

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
CVE-2026-94055
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-416
Updated
2026-11-02
EUVDEUVD-2026-83613 3.7

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
EUVD-2026-83613
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-jpgj-v2p6-hc2c 3.7

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after...

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
GHSA-jpgj-v2p6-hc2c
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-416
Updated
2026-11-02
NVD 3.7

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
CVE-2026-94055
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-416
Updated
2026-11-02
OSVDEBIAN-CVE-2026-94055 5.3

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
DEBIAN-CVE-2026-94055
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2026-94055 3.7

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

Record
UBUNTU-CVE-2026-94055
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUSN-8834-1 No score

exim4 vulnerabilities

It was discovered that Exim had an out-of-bounds write when Proxy-Protocol was used with an attacker-controlled proxy. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2026-94054)

It was discovered that Exim had a use-after-free when certain non-default TLS settings were used with GnuTLS. A remote attacker could possibly use this issue to cause Exim to crash, resulting in a denial of service. This issue only affected Ubuntu 26.04 LTS. (CVE-2026-94055)

It was discovered that Exim allowed attackers to read uninitialized data from stack memory when Proxy-Protocol was used with an attacker-controlled proxy. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2026-94056)

It was discovered that Exim allowed SMTP smuggling via crafted data sent after a rejection during DATA processing. A remote attacker could possibly use this issue to inject arbitrary email messages. (CVE-2026-94057)

Record
USN-8834-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
exim4
Debian:14
before 4.100.1-1, plus listed versions
4.100-14.100-1~bpo13+14.100-34.100-44.100~RC1-1
Show 38 moreShow less
4.100~RC2-14.100~RC3-14.100~RC3-24.98.2-14.98.2-1+hurd.14.98.2-24.99-14.99-24.99-34.99-44.99-4~bpo13+14.99-54.99-64.99-6~bpo13+14.99-74.99-7~bpo13+14.99.1-14.99.1-1~bpo13+14.99.1-24.99.1-34.99.1-44.99.1-54.99.1-64.99.2-14.99.2-1~bpo13+14.99.2-24.99.2-2~bpo13+14.99.3-14.99.3-24.99.3-2~bpo13+14.99.4-14.99.4-1~bpo13+14.99.4-24.99.4-2~bpo13+14.99~RC1-14.99~RC2-14.99~RC3-14.99~RC3-2
4.100.1-1
exim4
Ubuntu:26.04:LTS
before 4.99.1-1ubuntu1.5, plus listed versions
4.98.2-1ubuntu24.99-4ubuntu14.99.1-1ubuntu14.99.1-1ubuntu1.14.99.1-1ubuntu1.24.99.1-1ubuntu1.34.99.1-1ubuntu1.4
4.99.1-1ubuntu1.5
exim4
Ubuntu:22.04:LTS
before 4.95-4ubuntu2.12, plus listed versions
4.94.2-7ubuntu24.95-2ubuntu24.95-4ubuntu14.95-4ubuntu24.95-4ubuntu2.1
Show 10 moreShow less
4.95-4ubuntu2.24.95-4ubuntu2.34.95-4ubuntu2.44.95-4ubuntu2.54.95-4ubuntu2.64.95-4ubuntu2.74.95-4ubuntu2.84.95-4ubuntu2.94.95-4ubuntu2.104.95-4ubuntu2.11
4.95-4ubuntu2.12
exim4
Ubuntu:24.04:LTS
before 4.97-4ubuntu4.8, plus listed versions
4.96-17ubuntu24.96-17ubuntu2.14.97-3ubuntu14.97-4ubuntu14.97-4ubuntu3
Show 8 moreShow less
4.97-4ubuntu44.97-4ubuntu4.14.97-4ubuntu4.24.97-4ubuntu4.34.97-4ubuntu4.44.97-4ubuntu4.54.97-4ubuntu4.64.97-4ubuntu4.7
4.97-4ubuntu4.8

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-94055 is a low vulnerability (CVSS 3.7) in Exim, published September 19, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in exim4 4.100.1-1.

References

Show 4 moreShow less
MoveEnter Open