CVE-2026-94083
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup...
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
CVE-2026-94083- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Weakness
- CWE-843
- Updated
- 2026-11-02
EUVDEUVD-2026-83638
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
EUVD-2026-83638- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-4wwf-734g-mqm8
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup...
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
GHSA-4wwf-734g-mqm8- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Weakness
- CWE-843
- Updated
- 2026-11-02
NVD
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
CVE-2026-94083- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Weakness
- CWE-843
- Updated
- 2026-11-02
OSV
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
CVE-2026-94083- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Weakness
- CWE-843
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-94083
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
DEBIAN-CVE-2026-94083- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-94083
9.4
Suricata before 8.0.7 has a DoH2 type confusion that can cause an invalid free, because cleanup code for the HTTP2 state is executed even though the actual state is HTTP1 (when there is a DoH2 request with an HTTP1 to HTTP2 upgrade). This requires app-layer.protocols.doh2 to be enabled, which is the default in 8.x versions.
- Record
UBUNTU-CVE-2026-94083- CVSS 3.1
- 9.4 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
suricataDebian:13 |
All versions, plus listed versions 1:7.0.10-11:7.0.10-1+deb13u11:7.0.10-1+deb13u21:7.0.10-1+deb13u31:7.0.10-1+deb13u4 Show 24 moreShow less1:7.0.11-11:7.0.11-1~bpo13+11:8.0.0-1~exp11:8.0.0-1~exp21:8.0.0-1~exp41:8.0.0-1~exp51:8.0.1-11:8.0.1-21:8.0.1-31:8.0.1-3~bpo13+11:8.0.2-11:8.0.2-1~bpo13+11:8.0.3-11:8.0.3-1~bpo13+11:8.0.3-2~exp11:8.0.4-11:8.0.4-1~bpo13+11:8.0.5-11:8.0.5-1~bpo13+11:8.0.6-11:8.0.6-1~bpo13+11:8.0.7-11:8.0.7-1~bpo13+11:8.0.7-2~exp1 |
None known |
suricataDebian:14 |
before 1:8.0.7-1, plus listed versions 1:7.0.10-11:7.0.11-11:7.0.11-1~bpo13+11:8.0.0-1~exp11:8.0.0-1~exp2 Show 18 moreShow less1:8.0.0-1~exp41:8.0.0-1~exp51:8.0.1-11:8.0.1-21:8.0.1-31:8.0.1-3~bpo13+11:8.0.2-11:8.0.2-1~bpo13+11:8.0.3-11:8.0.3-1~bpo13+11:8.0.3-2~exp11:8.0.4-11:8.0.4-1~bpo13+11:8.0.5-11:8.0.5-1~bpo13+11:8.0.6-11:8.0.6-1~bpo13+11:8.0.7-1~bpo13+1 |
1:8.0.7-1 |
suricataUbuntu:16.04:LTS |
All versions, plus listed versions 2.0.8-1build12.0.9-12.0.10-12.0.10-22.0.11-13.0-1 |
None known |
suricataUbuntu:18.04:LTS |
All versions, plus listed versions 3.2-2ubuntu3 |
None known |
suricataUbuntu:22.04:LTS |
All versions, plus listed versions 1:6.0.4-21:6.0.4-3 |
None known |
suricataUbuntu:24.04:LTS |
All versions, plus listed versions 1:7.0.0-21:7.0.2-11:7.0.2-1build11:7.0.3-1build11:7.0.3-1build3 |
None known |
suricataUbuntu:26.10 |
All versions, plus listed versions 1:8.0.3-11:8.0.5-11:8.0.6-1 |
None known |
suricataUbuntu:26.04:LTS |
All versions, plus listed versions 1:7.0.10-11:8.0.1-3build11:8.0.2-11:8.0.2-1build11:8.0.3-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-94083 is a critical vulnerability (CVSS 9.4) in Oisf Suricata, published September 20, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in suricata 1:8.0.7-1.
References
forum.suricata.io/t/suricata-8-0-7-released/6467
github.com/OISF/suricata/commit/e574009add9c208f319e1d9d15b3bb1229c88074
github.com/OISF/suricata/compare/suricata-8.0.6...suricata-8.0.7
nvd.nist.gov/vuln/detail/CVE-2026-94083
github.com/advisories/GHSA-4wwf-734g-mqm8
github.com/CVEProject/cvelistV5/tree/main/cves/2026/94xxx/CVE-2026-94083.json
security-tracker.debian.org/tracker/CVE-2026-94083
ubuntu.com/security/CVE-2026-94083
cve.org/CVERecord?id=CVE-2026-94083