CVE-2026-94636
Apache Thrift: Python `TZlibTransport` stops enforcing its decompressed-size limit once the limit is exactly used up
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.2
Apache Thrift: Python `TZlibTransport` stops enforcing its decompressed-size limit once the limit is exactly used up
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
CVE-2026-94636- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Weakness
- CWE-409, CWE-628, CWE-1284
- Updated
- 2026-11-02
EUVDEUVD-2026-91560
8.2
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
EUVD-2026-91560- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-25j2-4rc9-8hj6
8.2
Improper handling of highly compressed data (data amplification), Function call with incorrectly...
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
GHSA-25j2-4rc9-8hj6- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-409
- Updated
- 2026-11-02
NVD
8.2
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
CVE-2026-94636- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-409, CWE-628, CWE-1284
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2026-94636
8.2
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
DEBIAN-CVE-2026-94636- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Updated
- 2026-11-02
OSVUBUNTU-CVE-2026-94636
8.2
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
UBUNTU-CVE-2026-94636- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - Updated
- 2026-11-02
OSVAZL-105410 No score
CVE-2026-94636 affecting package thrift for versions less than 0.25.0-1
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
AZL-105410- Updated
- 2026-11-02
OSVBIT-thrift-2026-94636 No score
Apache Thrift: Python `TZlibTransport` stops enforcing its decompressed-size limit once the limit is exactly used up
Improper handling of highly compressed data (data amplification), Function call with incorrectly specified arguments, Improper validation of specified quantity in input vulnerability in Apache Thrift py bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Record
BIT-thrift-2026-94636- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
thriftAzure Linux:3 |
before 0.25.0-1 | 0.25.0-1 |
thriftBitnami |
before 0.25.0 | 0.25.0 |
thriftDebian:12 |
All versions, plus listed versions 0.17.0-20.17.0-30.17.0-40.18.1-10.18.1-2 Show 16 moreShow less0.19.0-10.19.0-20.19.0-2.10.19.0-2.1~exp10.19.0-30.19.0-40.20.0-10.22.0-10.22.0-20.22.0-30.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2 |
None known |
thriftDebian:13 |
All versions, plus listed versions 0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3 Show 6 moreShow less0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2 |
None known |
thriftDebian:14 |
All versions, plus listed versions 0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3 Show 6 moreShow less0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2 |
None known |
python-thriftUbuntu:16.04:LTS |
All versions, plus listed versions 0.9.1-2 |
None known |
python-thriftUbuntu:18.04:LTS |
All versions, plus listed versions 0.9.1-2 |
None known |
thriftUbuntu:20.04:LTS |
All versions, plus listed versions 0.11.0-60.13.0-2build10.13.0-2build2 |
None known |
thriftUbuntu:22.04:LTS |
All versions, plus listed versions 0.13.0-6ubuntu10.13.0-6ubuntu20.13.0-6ubuntu30.13.0-70.16.0-2 |
None known |
thriftUbuntu:24.04:LTS |
All versions, plus listed versions 0.17.0-40.19.0-20.19.0-2build10.19.0-2.1build40.19.0-2.1build5 |
None known |
thriftUbuntu:26.10 |
All versions, plus listed versions 0.22.0-3ubuntu10.23.0-30.23.0-3ubuntu1 |
None known |
thriftUbuntu:26.04:LTS |
All versions, plus listed versions 0.19.0-4build10.22.0-30.22.0-3ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2026-94636 is a high vulnerability (CVSS 8.2) in Apache Software Foundation Thrift, published October 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in thrift 0.25.0-1.
References
lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1
lists.apache.org/thread/1rpq0d0g6yzjjzl1z27lwmvhzkn6rbrs
nvd.nist.gov/vuln/detail/CVE-2026-94636
github.com/advisories/GHSA-25j2-4rc9-8hj6
security-tracker.debian.org/tracker/CVE-2026-94636
ubuntu.com/security/CVE-2026-94636
cve.org/CVERecord?id=CVE-2026-94636