Every CVE Search/ Get API key

CVE-2026-96287

Apache Thrift: Perl `FramedTransport` reads and TLS socket writes re-slice the remaining buffer on every call (quadratic)

8.2 HighFix available

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.34%Down 0.1 points since Oct 3, 2026
90%50%10%1%

What each source reports

CVE List Score used 8.2

Apache Thrift: Perl `FramedTransport` reads and TLS socket writes re-slice the remaining buffer on every call (quadratic)

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
CVE-2026-96287
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness
CWE-407
Updated
2026-11-02
EUVDEUVD-2026-91576 8.2

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
EUVD-2026-91576
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-62v6-pgch-6j48 8.2

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings. This issue...

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
GHSA-62v6-pgch-6j48
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-407
Updated
2026-11-02
NVD 8.2

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
CVE-2026-96287
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-407
Updated
2026-11-02
OSVDEBIAN-CVE-2026-96287 8.2

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
DEBIAN-CVE-2026-96287
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2026-96287 8.2

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
UBUNTU-CVE-2026-96287
CVSS 4.0
8.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Updated
2026-11-02
Show 4 moreShow less
OSVAZL-105944 No score

CVE-2026-96287 affecting package thrift for versions less than 0.25.0-1

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
AZL-105944
Updated
2026-11-02
OSVBIT-thrift-2026-96287 No score

Apache Thrift: Perl `FramedTransport` reads and TLS socket writes re-slice the remaining buffer on every call (quadratic)

Inefficient Algorithmic Complexity vulnerability in Apache Thrift Perl bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Record
BIT-thrift-2026-96287
Updated
2026-11-02
OSVMGASA-2026-0562 No score

Updated arrow, thrift, ceph packages fix security vulnerabilities

The updated packages fix many security vulnerabilities. Please see the links for additional information.

Record
MGASA-2026-0562
Updated
2026-11-02
OSVopenSUSE-SU-2026:12051-1 No score

libthrift-0_25_0-0.25.0-1.1 on GA media

These are all security issues fixed in the libthrift-0_25_0-0.25.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12051-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
thrift
Azure Linux:3
before 0.25.0-1
0.25.0-1
thrift
Bitnami
before 0.25.0
0.25.0
thrift
Debian:12
All versions, plus listed versions
0.17.0-20.17.0-30.17.0-40.18.1-10.18.1-2
Show 16 moreShow less
0.19.0-10.19.0-20.19.0-2.10.19.0-2.1~exp10.19.0-30.19.0-40.20.0-10.22.0-10.22.0-20.22.0-30.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
thrift
Debian:13
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 6 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
thrift
Debian:14
All versions, plus listed versions
0.19.0-40.20.0-10.22.0-10.22.0-20.22.0-3
Show 6 moreShow less
0.22.0-40.23.0-10.23.0-20.23.0-30.24.0-10.24.0-2
None known
arrow
Mageia:10
From an advisory covering 14 CVEs
before 17.0.0-4.1.mga10
17.0.0-4.1.mga10
thrift
Mageia:10
From an advisory covering 14 CVEs
before 0.25.0-1.mga10
0.25.0-1.mga10
ceph
Mageia:10
From an advisory covering 14 CVEs
before 20.2.4-1.1.mga10
20.2.4-1.1.mga10
thrift
Ubuntu:20.04:LTS
All versions, plus listed versions
0.11.0-60.13.0-2build10.13.0-2build2
None known
thrift
Ubuntu:22.04:LTS
All versions, plus listed versions
0.13.0-6ubuntu10.13.0-6ubuntu20.13.0-6ubuntu30.13.0-70.16.0-2
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
thrift
Ubuntu:24.04:LTS
All versions, plus listed versions
0.17.0-40.19.0-20.19.0-2build10.19.0-2.1build40.19.0-2.1build5
None known
thrift
Ubuntu:26.10
All versions, plus listed versions
0.22.0-3ubuntu10.23.0-30.23.0-3ubuntu1
None known
thrift
Ubuntu:26.04:LTS
All versions, plus listed versions
0.19.0-4build10.22.0-30.22.0-3ubuntu1
None known
thrift
openSUSE:Tumbleweed
From an advisory covering 33 CVEs
before 0.25.0-1.1
0.25.0-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-96287 is a high vulnerability (CVSS 8.2) in Apache Software Foundation Thrift, published October 2, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in thrift 0.25.0-1.

References

Show 50 moreShow less
MoveEnter Open