Every CVE Search/ Get API key

CVE-2026-9638

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts

7.5 HighFix available

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.30%Up 0.3 points since Jun 13, 2026
90%50%10%1%

What each source reports

CVE List Score used 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
CVE-2026-9638
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-338
Updated
2026-11-02
EUVDEUVD-2026-36456 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
EUVD-2026-36456
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-3rw7-pf56-37cv 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts. These...

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
GHSA-3rw7-pf56-37cv
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-338
Updated
2026-11-02
NVD 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
CVE-2026-9638
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-338
Updated
2026-11-02
OSV 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts.

These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
CVE-2026-9638
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-338
Updated
2026-11-02
OSVDEBIAN-CVE-2026-9638 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts. These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
DEBIAN-CVE-2026-9638
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2026-9638 7.5

Crypt::PBKDF2 versions before 0.261630 for Perl generate insecure random values for salts. These versions use the built-in rand function, which is predictable and unsuitable for cryptography.

Record
UBUNTU-CVE-2026-9638
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2026:11034-1 No score

perl-Crypt-PBKDF2-0.261630-1.1 on GA media

These are all security issues fixed in the perl-Crypt-PBKDF2-0.261630-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:11034-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcrypt-pbkdf2-perl
Debian:12
before 0.261630-1~deb13u1~deb12u1, plus listed versions
0.161520-2
0.261630-1~deb13u1~deb12u1
libcrypt-pbkdf2-perl
Debian:13
before 0.261630-1~deb13u1, plus listed versions
0.161520-20.261630-1~deb13u1~deb12u1
0.261630-1~deb13u1
libcrypt-pbkdf2-perl
Debian:14
before 0.261630-1, plus listed versions
0.161520-20.261630-1~deb13u10.261630-1~deb13u1~deb12u1
0.261630-1
libcrypt-pbkdf2-perl
Ubuntu:16.04:LTS
All versions, plus listed versions
0.150900-10.160410-1
None known
libcrypt-pbkdf2-perl
Ubuntu:18.04:LTS
All versions, plus listed versions
0.161520-1
None known
libcrypt-pbkdf2-perl
Ubuntu:20.04:LTS
All versions, plus listed versions
0.161520-1
None known
libcrypt-pbkdf2-perl
Ubuntu:22.04:LTS
All versions, plus listed versions
0.161520-1
None known
libcrypt-pbkdf2-perl
Ubuntu:24.04:LTS
All versions, plus listed versions
0.161520-2
None known
libcrypt-pbkdf2-perl
Ubuntu:25.10
All versions, plus listed versions
0.161520-2
None known
libcrypt-pbkdf2-perl
Ubuntu:26.10
All versions, plus listed versions
0.161520-20.261630-1
None known
libcrypt-pbkdf2-perl
Ubuntu:26.04:LTS
All versions, plus listed versions
0.161520-2
None known
perl-Crypt-PBKDF2
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.261630-1.1
0.261630-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2026-9638 is a high vulnerability (CVSS 7.5) in Arodland Crypt::pbkdf2, published June 12, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.30%, the 23rd percentile. Fixed in libcrypt-pbkdf2-perl 0.261630-1~deb13u1~deb12u1.

References

Show 9 moreShow less
MoveEnter Open