DRUPAL-CONTRIB-2018-015
This module provides a JSON API standards-compliant API for accessing and manipulating Drupal content and configuration entities.
-
The module doesn't sufficiently associate cacheability metadata in certain situations thereby causing an access bypass vulnerability.
This vulnerability is mitigated by the fact that an attacker cannot trigger an exploitable situation themselves.
-
The module doesn't sufficiently check access in certain situations.
This vulnerability is mitigated by the fact that an attacker must have permission to create entities of certain content entity types.
Update: This is fixed in 8.x-1.10 not 8.x-1.9
What each source reports
OSV No score
This module provides a JSON API standards-compliant API for accessing and manipulating Drupal content and configuration entities.
-
The module doesn't sufficiently associate cacheability metadata in certain situations thereby causing an access bypass vulnerability.
This vulnerability is mitigated by the fact that an attacker cannot trigger an exploitable situation themselves.
-
The module doesn't sufficiently check access in certain situations.
This vulnerability is mitigated by the fact that an attacker must have permission to create entities of certain content entity types.
Update: This is fixed in 8.x-1.10 not 8.x-1.9
- Record
DRUPAL-CONTRIB-2018-015- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
drupal/jsonapiPackagist:https://packages.drupal.org/8 |
before 1.10.0 | 1.10.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
DRUPAL-CONTRIB-2018-015 is a vulnerability with no CVSS score yet in drupal/jsonapi, published February 21, 2018. No source lists public exploit code. Fixed in drupal/jsonapi 1.10.0.